FastDL not working

I’ve looked around for a day or two and still haven’t found a fix.

I host a Trouble in Terrorist Town server and I cannot get FastDL to work. No LUA errors in console or anything like that. Clients will be halfway through downloading a map and then it disconnects them with the missing map error.

My server.cfg




hostname "Evolution Gaming | Trouble in Terrorist Town" 

sv_loadingurl "http://titan-gaming.com/loadingscreen/ttt/Crystal/index.php?steamid=%s"

donate_url "http://evo-life.net/"

sv_downloadurl "http://risteh.site.nfoservers.com/ttt/garrysmod/"

sv_allowdownload "1"

sv_allowupload "1"

net_maxfilesize 64

//TTT commands - refer to http://ttt.badking.net/config-and-commands/convars


ttt_preptime_seconds 20

ttt_firstpreptime 60

ttt_posttime_seconds 10

ttt_detective_min_players 6

ttt_postround_dm 1

ttt_no_nade_throw_during_prep 1

ttt_karma_max 1100

ttt_ban_type ulx

ttt_namechange_bantime 1

ttt_detective_hats 1

ttt_allow_discomb_jump 1

ttt_spawn_wave_interval 5

ttt_weapon_carrying_range 150


ttt_playercolor_mode 0


I’ve tried setting sv_allowdownload and sv_allowupload to 0 and it still doesn’t work.

This is my fastdl.lua file located in lua/autorun/server. It only has one line because I’m using this sound as a test.



resource.AddFile( "sound/basscannon/bass1.mp3" )


Any help would be highly appreciated.

I believe all files must be compressed to .bz2, no?

I used SourceRSC to compress the files. I thought you only need to compress the .bsp’s?

Prefered, but not compulsory

[editline]31st January 2014[/editline]

Here’s my error log from joining your server:


Requesting 26 lua files from the server
ConVarRef ttt_basscannon_radius doesn't point to an existing ConVar
ConVarRef ttt_basscannon_shakescreen doesn't point to an existing ConVar
ConVarRef ttt_time_limit_minutes doesn't point to an existing ConVar
ConVarRef ttt_round_limit doesn't point to an existing ConVar
ConVarRef gmod_physiterations doesn't point to an existing ConVar
HTTP ERROR downloading http://risteh.site.nfoservers.com/ttt/garrysmod/resource/fonts/Aero_Matics_Display.ttf.bz2
HTTP ERROR downloading http://risteh.site.nfoservers.com/ttt/garrysmod/resource/fonts/Aero_Matics_Display.ttf
HTTP ERROR downloading http://risteh.site.nfoservers.com/ttt/garrysmod/materials/fc_ttthud/fc_ttthud_health.png.bz2
HTTP ERROR downloading http://risteh.site.nfoservers.com/ttt/garrysmod/materials/fc_ttthud/fc_ttthud_health.png
HTTP ERROR downloading http://risteh.site.nfoservers.com/ttt/garrysmod/materials/fc_ttthud/fc_ttthud_health_small.png.bz2
HTTP ERROR downloading http://risteh.site.nfoservers.com/ttt/garrysmod/materials/fc_ttthud/fc_ttthud_health_small.png
HTTP ERROR downloading http://risteh.site.nfoservers.com/ttt/garrysmod/materials/fc_ttthud/fc_ttthud_armor.png.bz2
HTTP ERROR downloading http://risteh.site.nfoservers.com/ttt/garrysmod/materials/fc_ttthud/fc_ttthud_armor.png
HTTP ERROR downloading http://risteh.site.nfoservers.com/ttt/garrysmod/materials/fc_ttthud/fc_ttthud_armor_small.png.bz2
HTTP ERROR downloading http://risteh.site.nfoservers.com/ttt/garrysmod/materials/fc_ttthud/fc_ttthud_armor_small.png
HTTP ERROR downloading http://risteh.site.nfoservers.com/ttt/garrysmod/materials/VGUI/ttt/icon_spykr_bomb.vtf.bz2
HTTP ERROR downloading http://risteh.site.nfoservers.com/ttt/garrysmod/materials/VGUI/ttt/icon_spykr_bomb.vtf
HTTP ERROR downloading http://risteh.site.nfoservers.com/ttt/garrysmod/materials/VGUI/ttt/icon_spykr_bomb.vmt.bz2
HTTP ERROR downloading http://risteh.site.nfoservers.com/ttt/garrysmod/materials/VGUI/ttt/icon_spykr_bomb.vmt

Simple Terms: These files are not found in the fastdl server

Now try.



HTTP ERROR downloading http://risteh.site.nfoservers.com/ttt/garrysmod/materials/VGUI/ttt/icon_spykr_bomb.vtf.bz2
HTTP ERROR downloading http://risteh.site.nfoservers.com/ttt/garrysmod/materials/VGUI/ttt/icon_spykr_bomb.vtf
HTTP ERROR downloading http://risteh.site.nfoservers.com/ttt/garrysmod/materials/VGUI/ttt/icon_spykr_bomb.vmt.bz2
HTTP ERROR downloading http://risteh.site.nfoservers.com/ttt/garrysmod/materials/VGUI/ttt/icon_spykr_bomb.vmt


Worked perfect, these are just from Spykr’s weapon picker, which he includes AddFiles for

Now go add those maps that I appear to be missing (You don’t need to add these to your download lua)

Also got booted for Lua Errors

ilya’s map vote system :stuck_out_tongue:



[ERROR] addons/ilyamapvote2/lua/autorun/client_mapvote.lua:196: bad argument #1 to 'pairs' (table expected, got nil)
  1. pairs - [C]:-1
   2. func - addons/ilyamapvote2/lua/autorun/client_mapvote.lua:196
    3. unknown - lua/includes/modules/net.lua:31




sv_kickerrornum 0

This should prevent kick, but that error should be looked at

What do you mean? The maps are in the FastDL.

If so, I wouldn’t be kicked for not having them

set sv_allowupload and sv_allowdownload to 0

I did what you said and I also removed the bz2’s of the maps and now there’s just the raw BSP’s in the FastDL and the clients can now download the maps and don’t get the missing map error!

But I still face the issue of all the other stuff not being able to be downloaded.

Maps should be in .bz2 format, along with everything else. You need to resource.AddFile EVERYTHING except the maps.

This is my current resources.lua. http://pastebin.com/A1Kdnjb3

I used that resource generator because Fox Warrior’s one would get a 3.0 Framework error when I tried to open a directory (I have Framework 4.5 installed).

Hey man,

Did you end up solving your Fast DL issues? Do you mind sharing your solution? I have the same problems too! :confused:

This page returns a 404 error.
http://risteh.site.nfoservers.com/ttt/garrysmod/

If you’re using .htaccess to restrict access, that may be your issue.

Since you are using NFOServers they have a preset line for your fastDL URL. You’ve changed it. It should be somewhere along the lines of

http://risteh.site.nfoservers.com/public/server

You may not have it at first because you need to access it via SCP.
As for compression, upload the files using FTP and do a websync from your control panel

Also your site has no folders for anything. Might wanna fix that

You should compress all the .bsp files to .bsp.bz2, then put all the normal .bsp files in your servers “maps” folder. Then take all the .bsp.bz2 files and put them in your fast dl folder “http://risteh.site.nfoservers.com/ttt/garrysmod/maps”.
If the map isn’t in your normal “maps” folder, then your client won’t download the maps.
On a separate note (if that does not work), then try re-naming all of your maps. Your failed attempt to get the maps to your clients could be causing client side bugs. Re-naming should fix that though.

Just keep maps at their default names. You shouldn’t be renaming the same version of a map.

Try making an addon containing everything you need for the server, it is very useful and I find it works better than doing each individual file, the only problem is maps, so check out this link near the middle, it shows code for a way to make players download the current map off the workshop.

Why use WorkshopDL when you have FastDL?

Also, we really should stop bumping the thread. Check the date.