FastDL only loads maps

Hi everyone,

I’m currently trying to set up a GMod server for me and my friends. Everything works fine after a bit of googling and try-and-error, except for one thing: FastDL.

Maps do load, but models, materials and so on do not. I used as a test this car: http://steamcommunity.com/sharedfiles/filedetails/?id=108903285
Added it to workshop.vdf, then unpacked it and uploaded everything except the \lua folder and info.txt. The server itself has the GMA file.
Created the garrysmod\lua\autorun\server\resources.lua with http://www.facepunch.com/showthread.php?t=842886.
Tried both resource.AddFile and resource.AddSingleFile. Tried both bz2ing and normal files on the FastDL. Permissions are 0755.

resources.lua:


resource.AddFile( "/scripts/vehicles/69charger-gm10.txt" )
...
...
resource.AddFile( "/materials/models/vehicles/cars/69charger/transparent_normal.vtf" )


My config on the FastDL:

http://sadpanda.us/images/1351883-AII4OK2.png

FastDL config in the server.cfg:


"sv_downloadurl"			"http://***/fastdl/gmod/"
"sv_allowdownload"			"0"
"sv_allowupload"			"0"

The maps load, the dodge appears in the “Vehicles” list, but the files don’t download. Any ideas what goes wrong?

Thanks in advance,
SeriTools

OK, found it:


resource.AddFile( "/models/vehicles/cars/69charger.vvd" )

needs to be


resource.AddFile( "models/vehicles/cars/69charger.vvd" )