FastDL (Possible resource file problem?)

Hey Guys, I originally hijacked someone elses thread with my posts, but I figured they’d get more sunlight as a standalone thread:

I’m currently having the a problem with gmod 13 and fastdl. I can connect to my server fine and it loads the addons I have in the spawn menu but theres no models/textures or anything. Just red errors for weapons and such. I have tried every combination of allowupload/allowdownload possibly, so I can atest that they are not the cause.

On the webserver side of things I used SourceRSC to upload my files, and it seemed to work flawlessly. I checked the permissions and everything is 755, so the files should be readable/executable by everyone.

Well if anyone has any info or was able to make there’s work I’m dying to find out how. Thanks!

Here is my server.cfg with masks over the sensitive areas:
“hostname” “XXXXXX”
“rcon_password” “XXXXXX”
“mp_flashlight” “1”

“sv_region” “0”
“sv_lan” “0”

“sv_allowupload” “5”
“sv_allowdownload” “5”
"sv_downloadurl “http://XXXXXX.net/garry/

“sv_voiceenable” “1”
“sv_alltalk” “1”

“sbox_godmode” “0”
“sbox_noclip” “0”
“sbox_weapons” “0”

“sbox_maxprops” “150”
“sbox_maxragdolls” “10”
“sbox_maxnpcs” “10”
“sbox_maxballoons” “10”
“sbox_maxeffects” “10”
“sbox_maxdynamite” “20”
“sbox_maxlamps” “20”
“sbox_maxthrusters” “20”
“sbox_maxwheels” “20”
“sbox_maxhoverballs” “20”
“sbox_maxvehicles” “20”
“sbox_maxbuttons” “20”
“sbox_maxemitters” “20”
“sbox_maxspawners” “5”
“sbox_maxturrets” “20”

[editline]30th January 2013[/editline]

Hi guys, I believe my issue could be related to my resource.lua file. I uploaded a map file to my fastdl server and that seemed to download quickly and work without issue, so to me that indicates it’s not an issue with my server.cfg or with the webserver I am using. The symptoms on the client side are that I can connect to my server without issue, never prompts or even attempts to download the missing files, but once in game the spawn icons/models/sounds/mats for my add-on weapons and such aren’t there. So the server is functional, and if you already have the same addons installed you wouldn’t even notice a problem, but I want to make this seamless for clients connecting to my server.

Instead it’s seems like it is either the file structure I am using on my webhost or my resource file. My webhost files can be seen here: http://sshme.net/garry/ My resource file is very long but if someone wants to take a look at it I can try to post it.

If anyone has any insight as to why nothing but the map file is working for me on fastdl I would be eternally indebted to them!

NOTE: I have already unpacked the addons into the base webhost folder “garry” so there is no longer a addons folder.

resource.AddFile is case sensitive, the file path must be the exact same on the lua file, web server, and game server.

Thanks elpishost, here is part of my resource file:
resource.AddFile( “/sound/weapons/psg1/psg_clipin.wav” )
resource.AddFile( “/sound/weapons/psg1/psg_clipout.wav” )
resource.AddFile( “/sound/weapons/r_bull/bullreload.wav” )
resource.AddFile( “/sound/weapons/r_bull/deagle-2.wav” )

My web server files (which are world viewable at http://sshme.net/garry/ ) seem to be in all lower case and in the correct directories. For instance: http://sshme.net/garry/sound/weapons/psg1/psg_clipin.wav exists and you can even listen to it using that link.

I just don’t know what I missed, but it must be something. At this point I’d even be willing to provide FTP access to my game and web servers if something thinks they can fix this!

Maybe instead of garry, make the folder name garrysmod

So I was actually able to figure something out… I used a different resource file generator and I am now much closer to my goal. It seems it is now able to successfully download almost everything:
Maps
Sounds
Spawn Icons in the q menu

But it doesn’t seem to be downloading models and/or mats, at least not correctly. When I click on one of the weapons to spawn it, I am given the weapon but it’s either invisible or a red error. At least I’m closer now.

@Sammy, thanks for the suggestion. I don’t think it’s the folder name (garry vs garrysmod) because I’ve been able to download maps via FastDL from the start. So it can find the folder without issue.

[editline]31st January 2013[/editline]

YESSSSSS! It works! My resource file must have been screwed up, I used a different generator: http://forum.facepunch.com/showthread.php?t=904405

And now it works!!! Thanks guys! Feel free to hit up my server if your into PvP.