FastDL problem - Almost giving up!

OK yes, hi there. Before asking, yes I did try every freaking(Excuse this) help / tutorial / support thing I could find and no, none of them work. Ok to start off, my resources lua is…


if (SERVER) then
resource.AddFile("models/code_gs/buzz/buzzplayer.mdl")
end

That is one of the things but the rest are VTF and VMT.

My problem is they won’t download from : http://unnilpentiumcraft.org/garrysmod or garrysmod/
Some of them are BZ2 and some are the original in case maybe it won’t work but however when I do the download, it will not download the model like that, but for some reason. When I attempt making it (“models/code_gs/buzz/buzzplayer.mdl.bz2”) it does start the download but then adds another bz2 extension e.g. bz2.bz2 so I am kind of in a twist and turn here and would love some help. Thanks. :slight_smile:

Did you put sv_downloadurl “http://unnilpentiumcraft.org/garrysmod” into your server config?

[editline]28th October 2014[/editline]

Are there any HTTP errors in client console when it tries to download the files when you join your server? If it does, post them here.

The error only occurs when I do the .bz2 in my resources lua and yes I have garrysmod in my server CFG and sv_download 1 and upload 0 but code error ->

OK, I don’t know how or why but now I see what I did wrong, I double checked and I apparently misspelled a few things. Pointshop wasn’t showing obviously because of the wrong model LINK and also the model downloaded as a bz2 but saved as a bz2 and yet still shows. So, my question is now would I really need VMT or VTF files to be downloaded or will just the model work?

[editline]28th October 2014[/editline]

oh wow, it worked. OK thanks for trying to help. Apparently the files staying in their bz2 form will work even if not extrated which is quite odd o_O?

The issue is that those have been bzipped twice. Noticed the .vtf.bz2**.bz2** the files should only say .vtf.bz2 on the end. Extract the files one time out, since they have been zipped twice.

Okay, I don’t see what happened but apparently people did download it and can see the playermodel but what’s more funny is how I have my files downloaded and they are in bz2 format but still show up. So I am seeing if this other guy who downloads will have bz2 or those texture files.

I helped someone else with this same problem; here’s a guide on how to set up FastDL with troubleshooting / problem solving: https://dl.dropboxusercontent.com/u/26074909/tutoring/server_srcds_steamcmd/fastdl_setup_instructions.lua.html

In there it tells you why FastDL does .bz2.bz2 and how to fix it.

Btw, yourstalker you are wrong ^. My files were not bzipped twice, only once but thanks for trying to point it out even if it is the incorrect information ^ Thanks.

I am however not having a bigger issue. I can’t become a prop on my prophunt server with E and yes I’ve tried changing pickup true and different versions but for some reason, no luck. It’s as if you can only pick them up but not become them? :S?

[editline]4th November 2014[/editline]

Delete this thread since useless as nobody is obviously helping anything.

Do yourself a favor and stop trying to host a server, someone tried to help and you’re just being plain rude because it isn’t the answer you wanted.
It’s quite clear that you aren’t up to hosting a server .

How bout this, if I prove to you that you are wrong and fix it for you, you post here saying “Stalker has a nice rack”. Deal?

lol, talking about rude. About 100% of you all are assholes and need to grow up. No, this is not a joke. every damn post / thread I’ve seen is nothing but you guys being half retard / half dumb / half brained.

It’s a videogame, it shouldn’t be serious. Anyways add me on Steam and when I’m home I’ll fix it for you. Then you post about my nice rack :slight_smile: