FastDL problem - May/June 2014

Hello!

I’ve found some weird problem in my GMod and also CS:s server (pardon for posting it here, but i don’t know what 's causing the problem).

I figured out by adding some new maps to my server. The FastDL wasn’t working anymore.
Looking back i remembered to added also some new models and materials but the game keep getting error and i thought of a problem of the models itself while it was FastDL!

This is really annoying since all players have to download manually files from FastDL repository.
Same thing happens with CS:S servers.

I don’t know if this is linked with the problem but Firefox was unable to download files from the file repository (http://phantommunity.it/gmod).

A player told me that it’s a problem common to many server after the last update.

Has anyone any clues about this? May-be source built in browser?
I tried to disable FastDL but it’s still missing files.

Thanks,
Luca

Post FULL console log after you have joined the server.

Hello!

Here are the logs:

As you can see it can’t download the map in any format altought the file is present. (.bsp, 2nd link)
It happens also with my counter strike source servers.
I don’t really know what to do.

We have discovered that with firefox you can’t download the maps. So we suppose it’s an error with in-game browser, but other servers seems not to have this problem.
We don’t have a really any clue about this.

i tried the links in the log you posted and i get what i believe is a 404 (i cant read it and google chrome says its italian and i didnt bother translating)

you need to bz2 those map files up and you should do all your other content as well (materials, models, sounds, etc)

get a program called zbzipper and run that on all of your files that are on your fastdl

What host are you using?

OVH

the file is present look here or click on the second link above. The map is not compressed but it should be downloaded anyway. It give just 4 links because it searched for every extension supported.
http://phantommunity.it/gmod/maps

It always worked but some time ago it stopped working and we don’t know why.

It’s NOT ONLY the maps. Addons, materials, sounds. All stopped being downloaded.
And since webserver is functioning and i can get connected to it, don’t know really what it could be.

post your server.cfg file here

I’m not sure why it wouldn’t download: http://phantommunity.it/gmod/maps/ttt_boogaloo_tower.bsp since it should fall back to .bsp if the .bz2 is missing, but you should try adding the bz2 and seeing if that fixes it.



hostname                "[ITA] Trouble in Terrorist Town - by Phantommunity.it v2.0!"
sv_downloadurl "http://phantommunity.it/gmod"
net_maxfilesize 1500
sv_allowupload 1
sv_allowdownload 1
sv_region               255
sv_lan                  0
sv_logbans              0
sv_noclipspeed          5
sv_noclipaccelerate     5
sv_cheats               0
sv_allowcslua           0

 
gamemode "terrortown"
ttt_lang_serverdefault "italian"
 
//other configs for ttt that i don't want to get public.
//not linked with fastdl in any way.


I don’t know if you guys are getting closer to the solution but it’s not only a problem of gmod and not only a problem of maps.
First i thought of a webserver problem, but as you can see everyone can download anything from there.
It just seem that i can’t download anything i put in fastdl, but only with gmod and firefox.

https://www.youtube.com/watch?v=kGx_5kIG1bU

Google is your friend.

Can’t you even read a topic?
:words:

P.S. Workshop != fastDL, i’m sure there is a google guide for dummies somewhere. You might need it.

It strangely fixed, maps get downloaded if in bz2 format.
Is this a bug? Maybe we should report it to the developers :stuck_out_tongue:

Thanks again, i’ll let you know if addons/materials/textures give other problems.