Fastdl problem. Or not ? Darkrp

My fast dl will allow others to download Gun packs and other addons. But it won’t let them download player models. I don’t know why. I’ve tried almost everything.

Here is the way I do it.

I download lets say “Police Models” Then I extract them with GMAD. Then I grab those files. And put them in a seperate folder named something like “Police Models” Then I put them in the Addons folder. then I go to Garrysmod/Gamemodes/gamemodes/darkrp/config/jobsrelated.lua (orwhatever its called) and I change the name of the job that I want changed. It works on my end. And only doesn’t work on my friends end because they don’t get the chance to download the files. Because the server doesn’t allow them to download them. And I don’t know why. It’s really getting on my nerves. I’ll read these messages when I wake up. Thanks.

This is for darkrp.

So show us your FastDL file?

Where do I find the fast dl file ?
you mean the server.cfg file ?

[editline]2nd May 2014[/editline]

The fastdl file is setup like this:

log on

hostname “Server Name Here”
rcon_password “Rcon Password Here”
sv_password “”
sv_region 255
sv_lan 0
gamemode “darkrp”
sv_logbans 0
sv_logecho 0
sv_logfile 1
sv_log_onefile 0
sv_noclipspeed 5
sv_noclipaccelerate 5

sbox_allownpcs 1
sbox_godmode 0
sbox_plpldamage 0
sbox_playergod 0
sbox_noclip 1

sbox_maxprops 150
sbox_maxragdolls 5
sbox_maxnpcs 10
sbox_maxballoons 10
sbox_maxeffects 50
sbox_maxdynamite 10
sbox_maxlamps 20
sbox_maxthrusters 30
sbox_maxwheels 20
sbox_maxhoverballs 20
sbox_maxvehicles 6
sbox_maxbuttons 20
sbox_maxsents 20
sbox_maxemitters 5
sbox_maxspawners 3
sbox_maxturrets 2

net_maxfilesize 30

sv_minrate 0
sv_maxrate 20000
decalfrequency 10
sv_maxupdaterate 66
sv_minupdaterate 10
sv_downloadurl “Fastdl URL Here”

// execute ban files
exec banned_ip.cfg
exec banned_user.cfg

I havent put the URL or Server there. Because I don’t feel like that would be a smart thing to do.
But the fastdl is working fine. Cause I installed Wiremod Precision Tool and Fists on the server. It’s only player models i’m having trouble with.

Maybe the way i’m installing them is incorrect?

No. That file you gave us is your server.cfg. If you have a webserver, like what nfoservers gives you, what you put in sv_downloadurl is “www.whatever.com/fastdl” But if you want to use dropbox for sv_downloadurl then go here: http://www.facepunch.com/threads/899166 But if you want to use scrds properties you can host a workshop collection provided with your steam api id

Your FastDL file is a file you create under lua/autorun/server and inside you add your DL’s.


resource.AddFile( "filepath" )
resource.AddWorkshop( "workshopID" ) -- Add Workshop is shit

These files are on your Webserver (as mentioned in the above post) or game server. You gave us your server.cfg (inside you include the sv_downloadurl “whateversite”)

[editline]2nd May 2014[/editline]

Also the models work for you because you already downloaded them and you never had a FastDl in the first place.

I’m running the server on a TCPanel and they have fastdl. And when I add the files. It doesn’t work. I’ve got my auth key and id from my workshop id. And It doesn’t accept models. It is only accepting other files.

I don’t understand what u wrote Aeternal.

All that is in the lua/autorun/server folder is sensorbones admin_functions.lua and cf.resources.lua

resource.AddFile has nothing to do with fastDL, and should not be referred to as “fast dl file”. It adds files for the client to download regardless of whether or not they’re using fastDL.

It’d be more appropriate to call it a resource file.

How exactly does this help me ;/ ?

It doesn’t. I wasn’t responding to you.

You have to create the resource/fastdl file your self

It doesn’t matter either way. That’s why I said Webserver or Game server. They don’t have to have FastDL cause they’ll just DL it anyways.

FastDL.lua or resource.lua you can call it penguins.lua and it wouldn’t matter. It does the same thing.

[editline]2nd May 2014[/editline]

Also your issue is that you haven’t actually added it to your resource.lua. You’ve only added the collection to your server and you aren’t telling them that they can DL it.

So how do I tell them that they can download it. And you said added it to my resource.lua is that a file i have to make ? or is it a preexisting file ?

And If I have to create it. Where do I put this file ?

You create a resource.lua file and put it in lua/autorun/server. If you want you can use AddWorkshop (they will re download it if they already have downloaded it) or extract it and use AddFile.

Here is a website that will help. Im assuming you have xenonservers cause of the control panel. http://www.xenonservers.com/clients/knowledgebase.php?action=displayarticle&id=67

I’ve done exactly what it says. And It isn’t working. I made a file called resources.lua in the right place.
And This is my code:

resource.AddFile(“models/bender/bender.mdl”
resource.AddFile(“models/farnsworth/farnsworth.mdl”)
resource.AddFile(“models/Agent_47/agent_47.mdl”)
resource.AddFile(“models/player/anon/anon.mdl”)

Is this correct ?

I fixed up the missing bracket. Still an issue. Not sure what it is. I’ve tried calling it resources.lua and FastDL.lua and none of it works. any ideas ?

Yes that is correct. And if it still doesnt work, go make a workshop collection then go into the command thing with all of the launch setting and put this in there.

No one else said it, so I’ll say it. Remove your rcon password from the server.cfg and put it into the command-line you use to launch your server.

I just experienced some trouble on my fastdl. I discovered that gmod for some reason is now reacting to upper and lower case with fastdl. I see in your OP that you have the path Garrysmod/Gamemodes/gamemodes/.
See if changing all directories to lower case will do the trick. remember to edit your resources file as well.