FastDL Problem

Fast dl is working fine but its being stupid I changed the map on my server and its not letting clients download it.

getting this error:

if you can help me that would be great.

sv_allowupload “1”
sv_allowdownload “1”
net_maxdownload <64>

net_maxfilesize 400
Should allow people to download all files that are up to 400 mb. I haven’t seen a map bigger than 400 mb (evocity is close), so that should do it.

that didnt work thanks thoidk why its not working.

Try setting sv_allowupload and sv_allowdownload to 0. Some people have issues with Fastdl with either one or both of them enabled.


"net_maxfilesize" = "16" min. 0.000000 max. 64.000000
 - Maximum allowed file size for uploading in MB


if you’re using FastDL then net_maxfilesize doesn’t even matter and you need to set sv_downloadurl

Make sure you’ve compressed it with bzip2 and have mime types set up correctly. The FollowSymlinks directive will need to be enabled if you’re using apache and you’ve symlinked it to your gmod folder.

Explain me how I couldn’t download a map from my FastDL untill I typed that. And that’s not just for me.

because you weren’t using FastDL…there are no file size limits with it enabled.

the net commands control source’s download system, not http redirects