FastDL Problem

Hello people!. I’ve been trying to set up my own FastDL, i currently placed all my materials, models, sounds and maps to a FTP server through my website. I linked it up to my server config and nothings happends, i tried to test with a map to see if it downloads through the FTP, but it dosent. Here is some information on how the FTP look on the cfg.

This is a gyazo link to a picture with the FTP Index:

A picture with the index of the folders that needs to be downloaded from server:

Just a picture from inside the materials folder:

The cfg. download section of it, is like this:

sv_downloadurl “ftp.bloodrise.com/garrysmod/
sv_allowupload “1”
sv_allowdownload “1”

Like seen on the picture 1, the downloadurl is just like that, i dont know if i need the whole url for it to work or anything, but please help out i need this help.

Try changing sv_downloadurl to “ftp://ftp.bloodrise.com/garrysmod

Tried but it still say’s “Missing Map”

Edit - Could it have something to do with that you have to put a password in when you acces it?

The password shouldn’t matter. Try entering the following commands in your server, joining, and pasting the output here.


developer 4
download_debug 1

You want me to put in in console or in cfg. ?

In your game’s console, then join the server and paste the text that was in it. Please wrap it in [noparse]




[/noparse] tags when you paste it though!

Here you go.


Loading: maps/rp_downtown_v2.bsp
No pure server whitelist. sv_pure = 0
Initializing renderer...
SOLID_VPHYSICS static prop with no vphysics model! (models/props_lab/corkboard001.mdl)
Need to rebuild map to get bumped lighting on material wood/woodfloor005a
Need to rebuild map to get bumped lighting on material maps/rp_downtown_v2/wood/woodwall009a_-1992_-1256_-632
Need to rebuild map to get bumped lighting on material maps/rp_downtown_v2/wood/woodwall009a_-4736_-1496_576
Couldn't find customization file 'sound/player/jingle.wav'.
clientside lua startup!
--- Missing Vgui material texturemissing
[DarkRP] Djarthas (STEAM_0:1:16090422) has joined the game
"materials/__vgui_texture_2.vtf": can't be found on disk
"materials/__vgui_texture_6.vtf": can't be found on disk
"materials/__vgui_texture_10.vtf": can't be found on disk
"materials/__vgui_texture_15.vtf": can't be found on disk
"materials/__vgui_texture_20.vtf": can't be found on disk
"materials/__vgui_texture_25.vtf": can't be found on disk
"materials/__vgui_texture_33.vtf": can't be found on disk
"materials/__vgui_texture_44.vtf": can't be found on disk
"materials/__vgui_texture_48.vtf": can't be found on disk
"materials/_rt_scope.vtf": can't be found on disk
Set Gravity 600.0 (0.250 tolerance)
Signon traffic "CLIENT":  incoming 100.250 KB, outgoing 20.805 KB
Queued Material System: ENABLED!
Compact freed 1204224 bytes
Error: Bad soundscape!
Redownloading all lightmaps
R_RedownloadAllLightmaps took 67.714 msec!
T

Edit - Banana. Maybe I got the file path all wrong on the FastDL I have. Im glad you are helping, I really need the help I can get from you!

Are you sure you ran those commands? There should be a bunch of green/red text in the console after joining with those commands

I ran those commands in console before i joined the server, I only get some red text about some files that couldnt be found.

it is probably not working because that is a ftp ulr, and you have to have a username and psw to login. Try putting the files into somewhere like bloodrise.com/fastdl

I see what you mean :slight_smile:

Would this work?
sv_downloadurl “http://bloodrise.com/fastdl/garrysmod/

I dont know if it works since it requires acces to type that in your browser.