FastDL- serious problems

Hello, Facepunchers.

The server I run just received a new upgrade- a FastDL directory. There’s a problem though.
It doesn’t download stuff properly.

I made a test to see what happens- I removed one map and one addon from my garrysmod folder, to see if the server will make me download them.
It did download the map, I was happy to see that. Then it also “downloaded” the addon. I was inside the server and started spawning entities from the addon mentioned. Errors.

So it seems it does work with maps, but not addons.

I’ve learned that all the addons on a FastDL server have to be extracted from their addons/folder dir to the root dir of gmod, meaning garrysmod/.
It took me long, but I did transfer the files in the way mentioned. Still- nothing.

I’ve tried all the server cfg settings-
sv_allowdownload/upload: 1/0

Nothing.

I’m sure the sv_downloadurl is correct, because it did download the map. I’m also updating the cache after performing any changes. I’d be grateful for some help, guys.

cool, i think you added me to steam

Please, guys. Help. I know there are people able to share some knowledge with me here…

**[Resource.AddFile

http://wiki.garrysmod.com/favicon.ico](http://wiki.garrysmod.com/?title=Resource.AddFile)**

I assume your problem is based around something like that.

That’s a situation where FastDL is NOT in use. You have to make a script in autorun containing Resource.AddFile.

Here, theoretically, the server should compare it’s content to what a player has, and if anything is missing, try downloading from an external directory pointed to by sv_downloadurl.

Maybe I don’t want the client downloading my broken fuckasslarge materials though…

What I have foudn to be the best settings:

sv_allowdownload 0
net_maxfilesize 64
sv_downloadurl “http://www.myfastdl.com/redirect” // you dont need the trailing / anymore

Update

It did require me to make a resource.AddDir/AddFile script. And it works.

New problem I haven’t noticed before: my admin addon doesn’t work (Exsto), and the same for PlayX. They’re both not even visible on the server.
They’re uploaded to both the game server and FastDL, extracted and resource.AddFile’d. What should I do? Now I’m clueless.

Define ‘not visible’. Does the Exsto menu command work?

It’s just as if the addons were not there at all. No trace of them. Not even in the console.

Then they aren’t loading, is the file structure right?

Yep. Also checked for upper-lowercase characters.

I am not sure about PlayX but with Exsto did you install it correctly?

Well, I can’t run a .bat file through ftp. Although, when I disabled FastDL, everything was working allright.

Btw. I’ve changed the admin mod to Evolve- same thing happens. Or… doesn’t happen actually. Nothing, no trace of it.

Add me on Steam, I’ll lend you a hand (Teamviewer, or if you’re that paranoid, a view session Teamviewer, and I can tell you what to do)

Alright, added you.