FastDL will not cooperate

I have read every possible guide on how to set up FastDL. It is set up, it works. Every file downloaded from FastDL ends up here:

http://puu.sh/kDogf.png

Now the first weird thing is that whenever a file is downloaded from my FastDL, it downloads the bz2 version, but also a non bz2 version. Unless I’m mistaken, that shouldn’t happen, as I don’t have the original file *anywhere *on my download server for the client to access.

Second weird thing is that even though the files are downloaded to that above folder, and as you see in the first picture this sound was clearly downloaded, the sound fails to load

http://puu.sh/kDony.jpg

What could I have possibly done wrong?

Does the sound actually work if you play it through Windows Media Player? Does it have a size?

Check the console for html errors after joining and dowbloading.
It may give you some error.
Unless, you dont have the server download stufd by fastdl, wich then should be done by sv_allowdownload 1

This happened actually with me too, even when I put the sound manually in the /sound/ directory, still found no fix, even though it was 41kHz as needed for gmod(I think)

Yes the sound has a size. No there are no HTML errors. sv_allowdownload is set to 0. Like I said, the files download just fine, and they end up in the downloads folder as shown in the first image. But what I don’t understand is why the sounds and other stuff do not “mount” once downloaded.

They should’ve mount.
Strange.
If its a sound when it will play, check as well the console, it may give an error

he checked the console as written above, it only says the sound cant be found(unmounted).

I’ve been having this problem too. (With a different sound file ofc).
I put the file both on the server and on fastdl, it downloads, aanndd… nothing.

But as for this statement:

That actually sounds like the file is not downloading at all?
That’s what happens when the server searches for a .bz2 but can’t find it, so it goes on to searching the .wav.
Unless you have the “.bz2” extension in your resource.Add(Single)File, that shouldn’t happen.

The client will try to download the bz2 version first, if it returns 404 or any other http error, it will try it without the bz2.
When using resource addfile etc. never specify the bz2 extension.
Does the sound load if you put it manually in your local folder?

Fyi, fastdl has really nothing to do with html (but with http).
Also sv_allowdownload should be 0 in garrysmod, because of security risks (google site:facepunch.com sv allowdownload exploit), setting it to 0 doesn’t affect fastdl.

If you have access to the fastdl hosts access.log and error.log you can look into these while joining, and see if the client can access the files correctly.

I have the problem with the sound too, but only with one single file. Could it be a problem with gmod?

I told in that post that you could do that.
Also, the server.cfg exploit it was fixed long time ago

I have correctly added the files to a lua file in the server autorun folder, where it uses resource.AddFile() and there is no bz2 extension. The bz2 is on the fastdl server, and it does download the files, like I said in the first post.

I can open all the downloaded files in Windows Media Player, and they work if I place them in the ‘sound’ folder. However, if I leave them in the ‘download’ folder, they do nothing and I cannot access them.

Can you take a look to your console for any red text when you try to play it?

If the sound is in the folder it downloads to, it does not play. The image in the first post shows this.

If the sound is in the ‘sound’ folder, it plays.

Is the sound in: download/sound/ ?

the wtc community I developed for, fixed it by using the sound in the workshop instead. :confused: try that whilst having a fastdl on, somehow works for them.

Well then that really does ruin the point of FastDL. But ok, I’ll try it.

Its not worth it for only one file

[editline]9th October 2015[/editline]

Now, can you answer what i asked you?

the fastdl still worked for them, but the sound downloaded through workshop :stuck_out_tongue:

[editline]9th October 2015[/editline]

“If the sound is in the folder it downloads to, it does not play. The image in the first post shows this.”

it AUTOMATICLY downloads it to the /downloads/sound/ folder.
besides mine was there too, and also didnt play. as you see above it occours for others too.

Well my point is that it’s not just this one sound. It’s EVERYTHING in my FastDL.

[video=youtube_share;gl47e0VJKhM]http://youtu.be/gl47e0VJKhM[/video]

Look in the bottom right and notice it downloading everything.
Geferon, you keep asking questions I addressed in the first post.

All of the files you see in the video are here, in .bz2 format.

http://puu.sh/kEd4L.png
inside my FastDL. Yet in the video, it finds the bz2 and then seems to ignore it. I don’t understand.