FCVAR_SERVER_CAN_EXECUTE prevented server running command: cider HELP!!

guys im getting this error on my gamemode

FCVAR_SERVER_CAN_EXECUTE prevented server running command: cider

please help i cant /dropmoney or something

[editline]01:20PM[/editline]

pleasE?

What document, which line? :effort:

there is no line? it just appear in the console

Scroll up. You must get an error somewhere.

there is a command cold “Dropmoney” i cant type this in chat “/dropmoney” but i can type this in the console “cider dropmoney”

^:doh:

you musteh gets teh errur in teh consolesorz tehn yu look at it and you wrait it hier yes



Registering gamemode 'Sandbox' derived from 'base'
Couldn't include file 'sh_init.lua' (File not found)
GRSRP\gamemode\core/libraries/sh_plugin.lua:11: table index is nil
Registering gamemode 'GRSRP' derived from 'Sandbox'


and this is the file



--[[
Name: "sh_plugin.lua".
Product: "Cider (Roleplay)".
--]]

cider.plugin = {};
cider.plugin.stored = {};

-- Register a new plugin.
function cider.plugin.register(plugin)
	cider.plugin.stored[plugin.name] = plugin;
end;

-- Call a function for all plugins.
function cider.plugin.call(name, ...)
	for k, v in pairs(cider.plugin.stored) do
		if (type(v[name]) == "function") then
			local success, message = pcall( v[name], unpack(arg) )
			
			-- Check to see if we did not success.
			if (!success) then Msg(message.."
"); end;
		end;
	end;
end;

-- Get a plugin by it's name.
function cider.plugin.get(name) return cider.plugin.stored[name]; end;


[editline]01:52PM[/editline]

Have you edited anything in the code, anywhere, in any documents?

well , i tried the original cider but its the same problem :’(

[editline]02:03PM[/editline]

the problem is that i cant do chat commands.

Do you have the SQL Database?

yes i do

[editline]02:04PM[/editline]

it works fine too.

Okay well, Im blank.

ok sadface

I think the plugins aren’t loaded correctly because you changed the folder name from cider to GRSRP.
Check the sh_init.lua in GRSRP/gamemode/, it loads the plugins there, check if you changed the folder to the new one(GRSRP)

I was thinking the same, when I noticed he changed it, but Ventmob did the same; they renamed it AppleJack.

You can fix this by using RunConsoleCommand instead of Player:ConCommand.

Yeah but that’s because I’ve completely rewritten the loading systems to be name independent. A lot of the stuff I’ve done in Applejack doesn’t work in cider, mainly because Applejack’s not Cider any more.

i fixed it , something was fucked up with the sql database.

I see. I wasent trying to offend you or anything, just pointed it out :slight_smile:

[editline]11:03PM[/editline]

:whip: