Fetching Workshop Addons - ERROR

Hi,
my dedicated server has 2 TTT Servers and 1 Darkrp but none of them can download anything from workshop. Any idea?


FIND [/home/cssserver/serverfiles/cstrike/*.vpk]
ADDING [/home/cssserver/serverfiles/cstrike/cstrike_pak_000.vpk]
Adding Path: [/home/cssserver/serverfiles/cstrike]
Couldn't load shader dll: game_shader_generic_garrysmod_srv.soConVarRef mat_dxlevel doesn't point to an existing ConVar
Game_srv.so loaded for "Garry's Mod"
Setting breakpad minidump AppID = 4000
Initializing Steam libraries for Workshop..
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
Fetching Workshop Addons..
Calling GetCollectionDetails
Error - retrying..
Calling GetCollectionDetails
Error - retrying..
Calling GetCollectionDetails
Connection to Steam servers successful.
   Public IP is 89.163.160.170.
Assigned anonymous gameserver Steam ID [A-1:324040712(7744)].
VAC secure mode is activated.
Error - retrying..
Calling GetCollectionDetails
Error - retrying..
Calling GetCollectionDetails
Error - retrying..
Adding Filesystem Addon '/home/gameserver/servers/89.163.160.170_27055/garrysmod/garrysmod/addons/_blogs-revamped-2-7'

Thanks in advance!

Care to try the Dev branch?

How is this going to help me?

There are major workshop changes in the dev branch

Hmm okay, I’ll try out. How do I switch to dev branch on my server. Have no experience with this

Scroll down to the bottom of that page.

It did not solve the problem :confused:

Side question:
Does anyone know a server crash detectror? Because since I’ve moved to dedicated my server crashes when a player joins. This happens 1-3 times and then they don’t crash for the whole day. Console doesn’t give errors.

Does it happen without any addons?

Nope, I have tried several collections and API Keys. But nothing worked. My provider will reset our server now. I seems that there is no other way.

Anyway thanks for ur help.