few issues (ulx and vgui)

Having issues with ulx- whenever I try to make a new group in the panel, it shows up with echo saying it was created, however, whenever it is attempted to use a command with that group it is said the group does not exist


[ERROR] addons/ulx/lua/ulx/xgui/commands.lua:151: Group does not exist (community officer)
  1. getGroupCanTarget - [C]:-1
   2. processRestrictions - addons/ulib/lua/ulib/shared/commands.lua:486
    3. calculateValidPlayers - addons/ulx/lua/ulx/xgui/commands.lua:151
     4. Open - addons/ulx/lua/ulx/xgui/commands.lua:33
      5. setselected - addons/ulx/lua/ulx/xgui/commands.lua:81
       6. OnRowSelected - addons/ulx/lua/ulx/xgui/commands.lua:305
        7. OnClickLine - lua/vgui/dlistview.lua:506
         8. unknown - lua/vgui/dlistview_line.lua:93

[ERROR] addons/ulx/lua/ulx/xgui/commands.lua:151: Group does not exist (community officer)
  1. getGroupCanTarget - [C]:-1
   2. processRestrictions - addons/ulib/lua/ulib/shared/commands.lua:486
    3. calculateValidPlayers - addons/ulx/lua/ulx/xgui/commands.lua:151
     4. obj - addons/ulx/lua/ulx/xgui/commands.lua:97
      5. func - addons/ulx/lua/ulx/modules/cl/xlib.lua:1080
       6. animQueue_call - addons/ulx/lua/ulx/modules/cl/xlib.lua:1061
        7. animQueue_start - addons/ulx/lua/ulx/modules/cl/xlib.lua:1048
         8. setselected - addons/ulx/lua/ulx/xgui/commands.lua:85
          9. OnRowSelected - addons/ulx/lua/ulx/xgui/commands.lua:305
           10. OnClickLine - lua/vgui/dlistview.lua:506
            11. unknown - lua/vgui/dlistview_line.lua:93

Even though, in data/ulx/groups.txt, the Community Officer group is there


"Community Officer"	
{
	"can_target"	"!%user, !%moderator"
	"allow"	
	{
		"ulx ban"
		"ulx banid"
		"ulx bring"
		"ulx chattime"
		"ulx csay"
		"ulx gag"
		"ulx gimp"
		"ulx goto"
		"ulx kick"
		"ulx kickafternamechanges"
		"ulx kickafternamechangescooldown"
		"ulx kickafternamechangeswarning"
		"ulx map"
		"ulx mute"
		"ulx playsound"
		"ulx reservedslots"
		"ulx rslots"
		"ulx rslotsmode"
		"ulx rslotsvisible"
		"ulx seeanonymousechoes"
		"ulx send"
		"ulx setgroupcantarget"
		"ulx showmotd"
		"ulx slap"
		"ulx slay"
		"ulx spawnecho"
		"ulx spectate"
		"ulx sslay"
		"ulx teleport"
		"ulx tsay"
		"ulx unban"
		"ulx unblind"
		"ulx uncloak"
		"ulx unfreeze"
		"ulx ungag"
		"ulx ungimp"
		"ulx ungod"
		"ulx unignite"
		"ulx unigniteall"
		"ulx unjail"
		"ulx unmute"
		"ulx veto"
		"ulx vote"
		"ulx voteban"
		"ulx votebanminvotes"
		"ulx votebansuccessratio"
		"ulx votekick"
		"ulx votekickminvotes"
		"ulx votekicksuccessratio"
		"ulx votemap2"
		"ulx votemap2minvotes"
		"ulx votemap2successratio"
		"ulx votemapenabled"
		"ulx votemapmapmode"
		"ulx votemapmintime"
		"ulx votemapminvotes"
		"ulx votemapsuccessratio"
		"ulx votemapvetotime"
		"ulx votemapwaittime"
		"ulx welcomemessage"
		"ulx whip"
		"xgui_managebans"
	}
	"inherit_from"	"operator"
}

I had to add that manually though. I have also tried deleting the group and redoing it from the panel. No dice…

Also, got this error. Don’t know if it caused any issues or if its caused by any recent addons installed


[ERROR] lua/vgui/dmenuoption.lua:73: attempt to call method 'OpenSubMenu' (a nil value)
  1. unknown - lua/vgui/dmenuoption.lua:73