Filter server list by compatible version

This seems to be getting more of a problem - or at least more noticeable lately

It would be very handy to be able to filter the server list by the current version of the client - it’s getting hard to find servers of the correct version lately.