Firearms Source with Darkrp

Again, minor issues.
Does anybody know how to correctly code FS guns into addentities.lua? I go to buy them and it just says /buy9mm or whichever gun in chat.
The addon is installed correctly, as I can spawn them in my Q menu.
Here is my addentities.lua:



AddEntity("M9 Beretta", {
	ent = "weapon_fas_m9",
	model = "models/weapons/a_m9.mdl",
	price = 230,
	max = 1,
	cmd = "/buym9",
	allowed = TEAM_GUN
})

AddEntity("M9 Beretta Silenced", {
	ent = "weapon_fas_m9s",
	model = "models/weapons/b_92sup.mdl",
	price = 270,
	max = 1,
	cmd = "/buym9s",
	allowed = TEAM_BMD
})

AddEntity("Glock", {
	ent = "weapon_fas_glock20",
	model = "models/weapons/a_glock20.mdl",
	price = 210,
	max = 1,
	cmd = "/buyglock20",
	allowed = TEAM_GUN
})

AddEntity("Machete", {
	ent = "weapon_fas_machete",
	model = "models/weapons/a_machete.mdl",
	price = 150,
	max = 1,
	cmd = "/buymachete",
	allowed = TEAM_BMD
})

AddEntity("Desert Eagle", {
	ent = "weapon_fas_deagle",
	model = "models/weapons/a_deserteagle.mdl",
	price = 280,
	max = 1,
	cmd = "/buydeagle",
	allowed = TEAM_BMD
})

AddEntity("M4A1 Rifle", {
	ent = "weapon_fas_m4carb",
	model = "models/weapons/a_m4.mdl",
	price = 500,
	max = 1,
	cmd = "/buym4",
	allowed = TEAM_BMD
})

AddEntity("MP5", {
	ent = "weapon_fas_mp5",
	model = "models/weapons/a_mp5.mdl",
	price = 450,
	max = 1,
	cmd = "/buymp5",
	allowed = TEAM_GUN
})

AddEntity("AK-47", {
	ent = "weapon_fas_ak47",
	model = "models/weapons/a_ak47.mdl",
	price = 580,
	max = 1,
	cmd = "/buyak",
	allowed = TEAM_BMD
})

AddEntity("Famas", {
	ent = "weapon_fas_famas",
	model = "models/weapons/a_famas.mdl",
	price = 510,
	max = 1,
	cmd = "/buyfamas",
	allowed = TEAM_BMD
})

AddEntity("Remington Shotgun", {
	ent = "weapon_fas_r870",
	model = "models/weapons/a_870.mdl",
	price = 400,
	max = 1,
	cmd = "/buy870",
	allowed = TEAM_BMD
})

AddEntity("Sako Machine Gun", {
	ent = "weapon_fas_sako",
	model = "models/weapons/a_sako.mdl",
	price = 500,
	max = 1,
	cmd = "/buysako",
	allowed = TEAM_BMD
})

-- ADD CUSTOM SHIPMENTS HERE(next line):



Did you make sure that model and entity are in the correct directory?

I have the .gma Addon extracted, but that is it.

Does the same 4 me

I know the guns work because I can spawn them along with ammo, which I have working. So it is something to do with the entitity…