First swep issues

Hi, I just got into swep makeing and am currently working on a new rilfe useing madcows base, But i am haveing issues.

I hexed the model and got it in game, It’s shootin and such now but i cant seem to fix the issue that it is stuck on my left hand. I tryed rehexing but still there, also for some reason the Sounds arent working ethier, can anyone help?

code?



// Variables that are used on both client and server 

SWEP.Base 				= "weapon_mad_base"

SWEP.ViewModel			= "models/weapons/v_rif_L85.mdl"
SWEP.WorldModel			= "models/weapons/w_rif_L85.mdl"

SWEP.Spawnable			= true
SWEP.AdminSpawnable		= false

SWEP.Primary.Sound 		= Sound("Weapon_L85a2.Single")
SWEP.Primary.Recoil		= 0.5
SWEP.Primary.Damage		= 17
SWEP.Primary.NumShots		= 1
SWEP.Primary.Cone			= 0.015
SWEP.Primary.Delay 		= 0.075

SWEP.Primary.ClipSize		= 25					// Size of a clip
SWEP.Primary.DefaultClip	= 25					// Default number of bullets in a clip
SWEP.Primary.Automatic		= true				// Automatic/Semi Auto
SWEP.Primary.Ammo			= "AirboatGun"

SWEP.Secondary.ClipSize		= -1					// Size of a clip
SWEP.Secondary.DefaultClip	= -1					// Default number of bullets in a clip
SWEP.Secondary.Automatic	= false				// Automatic/Semi Auto
SWEP.Secondary.Ammo		= "none"

SWEP.ShellEffect			= "effect_mad_shell_rifle"	// "effect_mad_shell_pistol" or "effect_mad_shell_rifle" or "effect_mad_shell_shotgun"
SWEP.ShellDelay			= 0

SWEP.Pistol				= false
SWEP.Rifle				= true
SWEP.Shotgun			= false
SWEP.Sniper				= false

SWEP.IronSightsPos              = Vector (2.6119, -4.4339, 0.3142)
SWEP.IronSightsAng              = Vector (-0.0435, -0.1986, -0.1663)
SWEP.RunArmOffset 		= Vector (1.7661, -3.2645, 1.9996)
SWEP.RunArmAngle	 		= Vector (-19.3086, 29.9962, 0)

SWEP.Burst				= true
SWEP.BurstShots			= 3
SWEP.BurstDelay			= 0.05
SWEP.BurstCounter			= 0
SWEP.BurstTimer			= 0

SWEP.Type				= 3
SWEP.Mode				= true

SWEP.data 				= {}
SWEP.data.NormalMsg		= "Switched to automatic."
SWEP.data.ModeMsg			= "Switched to burst fire mode."
SWEP.data.Delay			= 0.5
SWEP.data.Cone			= 0.75
SWEP.data.Damage			= 1
SWEP.data.Recoil			= 1

/*---------------------------------------------------------
   Name: SWEP:Precache()
   Desc: Use this function to precache stuff.
---------------------------------------------------------*/
function SWEP:Precache()

    	util.PrecacheSound("sound/weapons/L85/L85a2-1.wav")
end


put them in


 tags



Like this


No, put them in lua tags like this

lua
/lua

(with around them)

[LUA] example [/LUA]

Lua tags break, and you will have to press “Reply” to look at the mess, or copy it into your editor, which in length, gets annoying.

Lua tags work fine unless you are using IE.

[editline]07:44PM[/editline]

They also add line numbers and syntax highlighting.

[editline]07:44PM[/editline]

[noparse][lua][/lua][/noparse]

How do they break, and code tags are not much better than no tags at all.

[editline]07:46PM[/editline]

Lol I was trying to explain as simply as I could without it actually putting it as lua, damn I failed.

Sorry i am a huge noob… how do i put it in code format? :S

Put [noparse][lua][/lua][/noparse] around the code. [noparse] [lua][/noparse] before the code and then [noparse] [/lua] [/noparse] afterwards.

Thanks

back ontopic, Anyone know why I am haveing these issues?

Are you absolutely sure the viewmodel was not made to be left handed?

I downloaded it from FPSbanana, it was in the guys righthand in the video and pics. heres the model link

I’m sure it was made for the right hand. Prehaps i hexed it wrong?

EDIT: Woohooo, i got it fixed, i switched models. Tho this current one may not be as good as the one i wanted it will have to do. Thanks

Rebel, I have tried using Mad Cows base for a swep , and I came across this line in the lua, something like FlippedWeapon=1 or something,perhaps if you’re having trouble with the view model and not the world model thatll work.

Thats what was happening, i found it yesterday and turned it to false and it worked :> Working on its sounds now