Fix for yellow toolgun errors?

I haven’t played GMOD recently, and when I get on and select any tool, a huge list of repeated errors keeps popping up. I asked a few friends and they said it happened to everyone and that there is a fix, but I don’t know.

How could I fix it? And what happened? I don’t remember doing a garrys mod update.

Previous versions of Wiremod conflicts with the latest GMod update.
Update Wiremod. Update it using SVN. SVN Tutorial: http://www.facepunch.com/showthread.php?t=688324

Oh right. I have SVN, I just didn’t update it. thanks.

[editline]09:24PM[/editline]

Did not fix.

Help

Note that even though you updated wire, you still will get the errors on multiplayer servers. Becuase, chances are, they have yet to update it.

Seems a fresh restart of gmod + wiresvn did the trick.