Fixing Fingerposing problems

I’m kinda new to 3ds Max but I’ ve worked with other 3D programs before so I know how it works generally. I got a model with fingerposing but when I try it ingame I need to remove the restrict axis button and I have alot of trouble posing them. I would ike to know how I can fix them in 3ds max and how I can rotate bones without moving the mesh with it. Here is a little screen to help.
Thanks

http://filesmelt.com/dl/Help1.jpg

What I do is save the current skin envelopes (all the way at the bottom of the skin sidebar under advanced parameters) and remove the skin modifier. I then select all the bones and disconnect them via the unlink button at the top left of the window (2 squares.) I then select all the unlinked bones and go into the hierarchy tab (4 squares icon to the right of the blue arc) and pick affect pivot only. I then click on reset pivot. I then get out of the pivot only mode and use the rotate tool (I use the rotate box by right clicking on the rotate tool) and rotating all the bones at the same time. Resetting the pivot allows you to rotate each bone from their own respective pivots. After they have been rotated, link the bones back up, add the skin modifier to the model, add the necessary bones (probably all) to the skin, then load the skin envelopes under advanced parameters of the skin modifier. Make sure that before you load the envelopes in the new window, you click on match by name, so each bone loads into their correct envelope.

Thanks I will try it.

EDIT: I tried but when I stumbled across the option always affect mesh and just desactivated it and fixed, reactivated and it works. Thanks alot
Here is what I gave:
[img_thumb]http://filesmelt.com/dl/gm_construct002110.jpg[/img_thumb]

Wow from my experience I didn’t even know of that feature. Learn something knew every day heh. Glad it worked out.

saving out the skin data is important :slight_smile: a feature i love in max