Fixing the Hl2.exe has stopped working error.

Alright, alot of people have been struggling with the “hl2.exe has stop working” on the startup of the game.

Now, What i’ve done is, Modify the target.

It worked for most people that i told them.

First of, Open steam, and click Properties on Garry’s mod.

Set launch options and After the end of the sentence, add “-dxlevel 80”

This makes the game work, for alot of people that have been having the hl2.exe problem on the startup.

Thanks,

In english:

  1. open steam
  2. click garrysmod and select Properties.
  3. Set Launch Options
  4. Type -dxlevel 80
  5. Play Gmod

You’re right.