Flash light only working on random props

Please help this is a bug that has been annoying me for a full year, my flashlight works, its worked for ages, I DIDN’T get new addons since last time it worked and now its only working on general props, this isnt only for gmod as well this is happening in Left 4 Dead 2 & Half-life 2 as well. PLEASE HELP ITS BEEN LIKE THIS FOR AGES!


(User was banned for this post ("wrong section" - postal))

hmmm
you seem to be using XP or older which implies an older computer
can you give us info on your hardware?

Yes BUT it was working before ever since Gmod 11 when i first got it

Source has changed a lot since then.

did you already try forcing a lower direct x level like -dxlevel 81?

I’ll try that its just it was working even in Gmod 13 recently then i tryed re-installing, removing games, removing addons, nothing worked! But i will try that

[editline]29th August 2013[/editline]

It worked! Thanks a bunch though the only down side is my graphics are a bit worse, but that’s only noticeable with my physics gun, but please keep coming with ideas, I can do this for now but it would be nice to have a way i can have good graphics AND a good flashlight.

[editline]29th August 2013[/editline]

ok now the textures are bugging me, any other ways i can try fixing it while staying on direct x 9.0?

alright now some gamemodes arnt working like stop it slender, i need a way i can fix my flashlight and stay on the latest direct x please.

well shit
Can you tell us your specs?

Sorry what do you mean specs?

Specifications…
If you don’t know what that is, please use google to find out what this is and how to find it, this is basic computing knowledge…

Ah ok sorry

Mainly what I’m asking for you to give us is the model of your graphics accelerator. If you can figure that out we might be able to tell you whether you’re screwed or not.