"Flatten" a DModelPanel

I’m in the process of making a class selection menu and the models aren’t the way I need them to be - in TF2, they appear flat as if they’re a part of the background - in my menu, they appear 3D, like they’re overlayed and aren’t part of the background.

I’ve tried messing around with the FOV and stuff, to no avail.

https://dl.dropboxusercontent.com/u/16737046/tf2test.png

Also - Could anyone help me with the “fleshy” appearance? They’re supposed to be shiny like they are in TF2.

it looks to me like you need to enable fullbright on the model. either that or change the paint function’s directional light to be above and closer to the model.

They are already fullbright - and the directional light doesn’t do it either.

Here’s a better example of the “3D” effect.

http://cloud-2.steampowered.com/ugc/882986798644838817/B0A6B5CCFF3B27361846713DA60C73AE015AF8F6/1024x576.resizedimage