Fog Problem

Hello

I am having a problem with fog in my map.

(refer to picture). The fog should be fading out, but instead you can clearly see the map clipping.

The “Far Z Clip Plane” is higher than “Fog End”, but it still clips.

Does anyone know why? Thank you

http://img64.imageshack.us/img64/6606/fogproblem2.jpg

http://img695.imageshack.us/img695/859/fogproblem.jpg

Do you have a 3D skybox in the map? If so, set the sky_camera’s fog to the same settings as your main map fog. Also, reduce the damn density and change the colour.

FarZ clip plane means it clips the world at that far away from you. If you don’t like it, raise how far it is. It clips everything.

I am confused. I have set it to 7500, but it won’t blend.

How do I make it blend, then? I want it to be seamless.

There is also no 3d skybox.

Your skybox texture needs to match your fog color to give the effect of fading away

So a good skybox texture to use is sky_day02_10
or make you own where most of the horizon is just one color

The clip settings you have are correct, it’s just that fog doesn’t apply to the skybox in the background, which makes it seem like it’s being clipped closer than it should.

Make a custom skybox of just 1 flat color (the exact color of your fog) and your problem will be fixed.

You could just put an extremely high value in the z clipping plane. That eliminates the clipping, everything behind fog end will be rendered then tho, even if its all white, so if you want the clipping plane for optimization reasons, you should do what was suggested above.

So I can’t use my current sky texture while have it fading?

either raise the clipping distance enourmously or use a sky that has a similar colour as your fog. the current sky doesn’t fit to a foggy environment anyway, tho.