Fonts aren't working

I’ve been stuck on this for a while and thought I would ask here. I’m trying to make a DLabel for the title of a panel using the font found here: http://www.dafont.com/thirsty-script.font. However, the label doesn’t show as that font; it’s just a regular font like the one I’m typing with right now. I’ve created the font with surface.CreateFont, I know I set it correctly on the labels font, but it doesn’t use the right one. I’ve also tried using a similar font to see if that worked. No luck there either.

Creating the font:



        surface.CreateFont( "TitleFont", {
	font = "ThirstyScriptExtraBoldDemo",
	size = 24,
	weight = 500,
} )

Is the font’s name ThirstyScriptExtraBoldDemo.ttf and is it located in resource/fonts?

The name is ThirstyScriptExtraBoldDemo.otf but I’ve also used ones that are ttf that haven’t worked. And yes they are in resource/fonts.

otf fonts are unsupported; you must use a ttf font.

Thanks for that heads up then. I’ll try a ttf font again and see if that works.

[editline]7th September 2014[/editline]

Ok here’s the other one that I tried that didn’t work either and it still doesn’t: http://www.dafont.com/deftone-stylus.font

Bump, any ideas?

When you open the font in a Font Viewer program; use the name of the font listed in that window. Don’t use <name>.ttf, use the name listed in the font-viewer.

Actually lobster by default it’s otf (I converted to ttf so people can download it)
But seems like source can’t install otf fonts like ttf ones, but if you have otf font installed you can use them