Force DL Issue

Hello all, I have been trying for hours to get my force DL when joining the server to work but with no success. It just ignores it and goes straight to sending client info.

Here are a few images of my setup and what it looks like:

http://imageshack.us/a/img145/9578/help2r.jpg
http://imageshack.us/a/img805/4990/help1x.jpg

http://steaknbeer.com/garrysmod/ - This is the Fast DL site, Just have a look [Ignore addons folder, it was just a test]

Also please note, I’ve changed the values of sv_allowdownload/upload with every combinartion with no success.

So what could my issue be?

[EDITED]

Not that I would know but shouldn’t sv_allowdownload be 1 if you want to be able to download shit? Also you have the fastdl listed as http://steaknbeer.com/garrysmod/ in your server.cfg. Also on your web server do you have the correct CHMOD 755. Other than those things I would not know what to say. On another note you only need to add .vmt files and .mdl files the related files will be added accordingly.

Sorry I forgot to mention Sv_allowdownload was set to 1, It has just been changed as we tried every combination.

Sorry, friend changed the url last night. [Edited Original Post]

sv_allowupload has nothing to do with FastDL.

Make sure your links are formatted as so… http://website.com/garrysmod

Make sure your stuff is resource.AddFiled

Ok so here is what me and Mattaust have done so far

Ok so the map is downloading off the server no problems this im sure so the url and webserver are working correctly however the addons are not being forced i have followed this link http://www.facepunch.com/showthread.php?t=1242975 but come to the same ending that it isnt forcing people to download if you go to http://steaknbeer.com/garrysmod you can see the folder layouts and the addon folder was just me testing but that didnt work ethier.

Cheers for any help

I have some type of problem that makes me allways want to do and help people with forceDLing stuff. Just add me on steam if you still need help. (PS- my steam name is the same as this name, friend the one with the dog as the picture)

Ok cheers, sent you a friend request via steam, I appreciate all your feedback. I’ll post something when I get it to work to help other people who search for this problem, as when I searched. All forums address the question but get to no successful conclusion

I hear sv_allowupload had or has an exploit if its set to 1… I’d avoid using it. Unless you know how to use it properly, I sure as hell don’t lol.

I’m pretty sure it’s resource.AddFile(“materials/directory/file.vtf”) and not resource.AddFile("/materials/directory/file.vtf") or does it work both ways?

^ Cheers MIB that was the issue changed from /materials/ to just materials/ in the resources lua and it worked fine.

Thanks!

Good you found a solution but really, “was have been”? I’m generally not a grammar nazi but this just kept nagging in my head :tinfoil:.

^ I rushed typed it or it happened when I made an edit… lol

Fixed for you and others when they need help with similar issue.