Force Download no longer working?

Please forgive me if this isn’t the correct topic. I couldn’t decide between this one and the developer discussion…

It seems after the last patch or so force downloading in Gmod is no longer functioning and I don’t know why. Just to be sure I wasn’t doing anything incorrectly I followed what was listed here:

and created a fresh resource.lua file and added a few maps to it. Upon connecting the client is not requested to download any files.


-- lua\autorun\server\resource.lua
if (server) then
resource.AddFile("maps/ttt_minecraft_b5")  (Tried with .bsp as well)
resource.AddFile("maps/rp_downtown_v2_fiend_v2b")
end

Server.cfg


sv_allowupload "0"
sv_allowdownload "1"(Tried 0 as well)
sv_downloadurl "http://csscrim.site.nfoservers.com/server"

Use resource.AddWorkshop( ‘WorkshopID’ )

Is resource.AddFile no longer a thing? Only workshop items can be force downloaded?

Workshop items can be force downloaded now. I’ve noticed that it’s relatively fast when connecting to a server that has workshop downloads. It also shows how much of the file has downloaded in the small status bar at the bottom right of the window when you connect, which is really nice. If you make a content pack for your server on the workshop it could be easier to maintain, too.

I have the same problem, i dont want to use the fcking workshop. I want my FastDL. Pls need fix Garry!!

It is still works for me BUT, resource.AddWorkshop() is alot faster and you can upload everything in one go without adding resource.AddFile(“filepathhere”) x1000 in a lua file.

EDIT - More info on garry’s blog

Okay Thank you. I will try it!!!

I appreciate the responses but none of them really answer my question.

I can no longer get resource.AddSingleFile or resource.AddFile to work in the latest versions of Gmod. Does anyone have any idea?

I am getting a error when trying to add maps to the work shop, help?

resource.AddFile works on models and materials. Can’t force download on any custom sounds on my end.