Forced DirectX 8 Issue

A few of us have brought this up over on the steam forums but I couldn’t find a post about it here (sorry if I missed it).
Basically the issue I and some others are having is that our directX hardware level is being forced to 8. I am currently using a GTX460 which is a directX 11 capable card and have never had this issue before, I have also updated my directX runtime from the Microsoft website and have the latest graphics drivers so do not believe this to be a problem at my end.
Annoyingly, due to being forced to use directX 8, many graphics settings have become greyed out and I am experiencing some very odd lighting effects in-game which have put me off playing for now. Is there a fix for this issue or could it possibly be a bug from a recent update?

[editline]18th June 2013[/editline]

Ok so I just had a quick scroll further back into the forums and came across this post here: http://forum.facepunch.com/showthread.php?t=1276317.
The advice given was to use the startup command -dxlevel 90 as a launch command which has thankfully fixed my issue. (Sadly my video settings now reset every time I play but at least it works!)

However, the last post on the other thread says that this problem was fixed in the 13.06.07 update and we’re now on 13.06.11 so I’m not entirely sure the “fix” worked :frowning:

I had the same problem Try remove startup command and do this.

https://dl.dropboxusercontent.com/u/130137401/Untitled1.png

It works for me.

Or put this in your launch options


-dxlevel 95

That’s the latest version of DX that it can support

I have tried that but it didn’t help me. Only gmod runs on directX 9. I don’t know why but if I remove this command the game runs normally (directX 9.0 and video settings are saved).

So it’s solved?

[editline]18th June 2013[/editline]

I think only certain hardware only suports dxlevel 95 anyways