FPS and Screen problem

Before I go any further:


Pentium D @ 3.40GHZ

GeForce 9500GT with 1GB memory

2.99 GB of RAM

OS Windows XP Professional

DirectX 10.0

Note: I have never had any problems with Gmod before with those specs.

Hello. I have been noticing lately that after that weird Gmod update that caused some problems that I even had some problems.

Here they are:

  1. Gmod looks really nice and all but my framerate dropped horribly. By nice and all, it looked good before the update, with normal framerate, but after that update, it looks WAY better and framerate has dropped HORRIBLY.

I mean horribly as in going from 250-300FPS in singleplayer down to a 60-80FPS.

And normally 120 - 140 FPS in multiplayer (with some props) down to a 50-60.

  1. Also, I noticed another thing: My screen size changed. Originally it was 1024 by 768. Now it turned into 1280 by 1024 (native). What does “(native)” mean? It doesn’t really look good in the startup screen to me. It is all small and such. I change it back to 1024 by 768 but everytime I play, it turns back to 1280 by 1024 (native).

There is alot more to be solved, but those are the 2 major things. If anyone else experiences this, please post if you have figured it out.

PLEASE HELP ME :slight_smile:

Thank you.

Native means it uses the best possible resolution that fits your screen. Try playing a game at 1024 by 768 and loo in the distance, on edges and stuff. Now switch to 1280 by 1024. Doesn’t it look much better? You have a flat screen right? And btw, with the native resolution, you have extra space in your spawnmenu. Which is nice to have

i try not to sound like an ass but im jsut gonna say

Are you srs man? people crashing here, and u just come and ask
“why is my perfect fps going down to perfect fps? wtf”

60fps is good. u can deal with that. now let the people who are crashing and unable to start gmod, talk
please :smiley:

Yes I have a flat screen. I am still concerned though. I know it looks better, but I really want my FPS back. Is there a way to fix it? My settings on my nVIDIA options say my screen is at 1280 by 1024.

Oh and a maybe 1 - 2 weeks before that I got that 9500GT and got DX10. Gmod looked WAY better with just X2 antiliasing. I put it their since it is the lowest level so it won’t just eat away at my graphics card. As far as the other options go, I don’t know what happened.

Have you tried going to Gmod settings> Video> Advanced options? Try setting some of them to medium, and take vertical sync (Aka v-sync) off.

Actually, I haven’t. I’ll check it out tomorrow since I gotta go to sleep. I will get back to you though!

You can’t get back to me, lol. Ill be back in a week after my vacation.
Shadows are one of the fps-killers. Atleast for some graphics cards, that is


Still getting bad FPS. I know it sounds like a stupid problem, but whenever I spawn something my FPS drops. When it was normal, it didn’t.

I hope there is a fix soon, or if anyone can help me out. (Again :C)

Update your video drives.

Did already. I check for updates daily now. I want to see if anything is going to make a difference by now.

Hopefully it will return back to normal.

Just out of curiosity why do you have DirectX10 on XP.

It downloaded with my driver disk.