Fps dips real low. Cpu specs inside. Help plz!!

Hey gang, Im sure this topic has been beat to death but maybe someone has an answer that I haven’t yet considered.

My frames peak at 33 at a standstill. When running and looking around range between 17-28, and when hitting barrels, engaging in fights, or anything with action on the screen fall to 6-12 fps. The real low dips in result in me completely freezing and coming back after 4 seconds, roughly.

Id like to see the low dips go away. I can suffer through the 25-35 fps if I must. However, the massive drop during any sort of action makes this game unplayable.

Cpu:
Fx990 Fatility gaming mobo
Amd fx8350 8 core 4.2 processor
Nvidia 970 gtx ssc
8 gb ram
Windows 7 Professional 64bit
I play borderless screen on 1920x1080
Also tried 1920x1080 windowed, 1280x960 borderless and windowed.

Server: NY Facepunch - Ping range 38-65 same results on Rustopia, Rusty Trombone and unplayable on battle fields.

Things Ive checked/tried:
My gpu is listed as the gpu in the f1 console command system info
My frames are set up as -1 in config
Unigine Heaven benchmark tests are normal
Unparking cores
Gpu and Cpu heat temps are stable
I have my EVGA Precision X running on the 2nd monitor, the card will actually OC to compensate for fps lag but doesnt fix it

I need some help fellas

Have you checked to see if rust is maxing out your ram? Those frames don’t seem right at all.

Try running perfmon and see what’s happening as you play the game.

I’d say the ram too, I’m not sure the unity ram leak has been fixed entirely and 8 gig is pushing it

EDIT

what resolution are you playing on?

All good questions guys. I will update the information above in the original post.

[editline]18th January 2016[/editline]

Cpu RAM or Gpu RAM?

[editline]18th January 2016[/editline]

Not familiar with that program

I ran Perfmon. It didn’t reveal anything that seemed unordinary.

  • My CPU usage was around 27% with 83% Maximum frequency.
  • Physical memory being used 49%

OK, I’d suggest your hardware is good then. Try turning off PVT (procedural virtual texturing) and ambient occlusion. These make huge differences to my performance

-forced3d9
play at 800x600
play on fastest
disable everything graphical

benchmark and get back to us

I had the same problem on my I5 4670/ gtx 970 rig…I disabled cpu parking in Windows and now I see 50+fps with dips into the 30fps range. Apparently not all cores were being used.

No game uses all cores really, and parking simply turns a core off when it’s not needed, this shouldn’t have changed anything. Do some research, Unparking your cores should in 99% of cases have absolutely no change at all. Windows should automatically turn those cores back on.

My cores are unparked. No change.

[editline]21st January 2016[/editline]

I’m not sure what you mean by “forced3d9”

When I unparked my cores, I gained 20 fps instantly. So that’s weird.

Actually I did do some research and it revealed that other people discovered that cpu cores were not being activated in a timely manor. Disabling parking made a difference for them and for me so I thought I would pass that little tidbit along…

Thanks for the threads. Unparking cores helped me quite a bit. I went from dx9 fastest to the dx11 fantastic setting. I am testing this thread right now. FPS are usually 60 to 80 with drops to 30. Game issue?