Frame-Rate dropping!

When ever I play gmod, I go onto a server. And every 10-25 minutes my frame rate drops to about 5-11 frames. And laggs for about 30 seconds - 1 minute, then goes away for another 10-25 minutes, and so on. It just started this about 3 week ago. And it seems to be getting worse.

It only does this on multiplayer. Doesn’t seem to lagg at all in single. I get about 50 - 130 fps.

Specs:

AMD Phenom X3 triple core
Asus M3A78-CM mobo
4 GBS of DDR2
ATI HD 5450

I think that your processor is busy at that moment…

Nothing is running but steam and gmod.

could also be overheating, but normally that just causes crashes or slowdowns until you shut the computer down. Are you sure nothings updating automatically while you’re playing?

There is nothing running, but steam and the game itself. Windows has auto update turned off. So I can’t be that.

What’s your OS? Because it has been shown over and over and over again that Windows 7 hates Source and/or vice-versa.

You have three cores, right? Start GMod, Ctrl+Alt+Delete, Processes, right-click on hl2.exe, Set Affinity…, and set the affinity to only one core. You will, unfortunately, have to do this every time you start GMod. There are programs out there that can do this automatically, but they are not often free.

If you STILL get poor framerate, and even if you don’t, add this to an autoexec.cfg. It’ll help reduce stuttering and decrease map load times when going from one map to another.


echo
echo Executing autoexec.cfg...
echo

//Stuff from Quantum's Little Config. (Thanks, Quantum!)
datacachesize 128 //GeneralDataCache in MB. Use 64MB for 1GB, 128MB for >= 2GB
mem_max_heapsize 2048 //MAY CAUSE INSTABILITY. Has to be set higher because of CommandLineCommand "-heapsize"| Maximum amount of memory to dedicate to engine hunk and datacache, dont user more then half of your Memory

// Other
cl_forcepreload 1 //Force texture preloading
sv_forcepreload 1

echo
echo Autoexec.cfg executed!
echo

mem_max_heapsize may cause instability, so if you get instability, try commenting it or setting it lower (say, 1536) and seeing if you still get instability. If you continue to get instability, continue to lower me_max_heapsize. Do not set it lower than 256 (its default).

Also, add this to your launch options:

-noforcemaccel -noforcemparms -noforcemspd -noipx -nojoy

If you use a joystick, remove -nojoy.

I hope this helps.

How many addons do you have? Does this happen in every server in multiplayer?

Wiremod, PHX, PlugV2, some player models I made, Smart Constraint, and gm_flatgrass2008.

Yes, every multiplayer game.

OK. I fixed it finally.

For some reason I had some messed up files in my cache folder. I deleted it, works great now.