Fredrick won't animate "T"

Im having a slight problem in a gamemode i’m working on, player models wont animate, instead the just take on a T shape and their limbs wont move. If you dont understand,

http://cloud.steampowered.com/ugc/542897235610542357/11F2790F8A82CA7903942F8148CFB85DC6EE8029/

How do i fix this problem, ive tried changing the model, when i set the model, caching the model, it doesn’t seem to help. Thanks in advance.

Unless you overwrote CalcMainActivity, the model you set the player to doesn’t have the animations it is trying to play and defaults to ACT_INVALID.

Haven’t overwritten CalcMainActivity.

Then do it.

Just did, with the original source from base , no change.

Sorry this doesn’t help with your question, but how do you add multiple bots? I can only get one bot in at once using rcon and the console… :stuck_out_tongue:

I type “bot” multiple times in console.

[editline]22nd June 2011[/editline]



function GM:PlayerSetModel(ply)
   local mdl = ply.WantedModel or "models/humans/group01/male_01.mdl"
   util.PrecacheModel(mdl)
   ply:SetModel(mdl)
end


Does somebody see something wrong with this?
Because it is when i remove this override it seems to magically work, minus my models being set.

I see what i did wrong, really was getting pissed off, and this is kinda stupid if you ask me.
I was using:
“models/humans/group01/male_01.mdl”
which is the exact same model as
“models/player/group01/male_01.mdl”
except the later can be used as a player model. FML >.<, 2 hours wasted

LOL. I’m an idiot! I forgot that I had the player limit at 2 and I was in the game when I tried adding a second bot >.<’ Wow…