Freezing at Send Client Info

So, I’ve been playing Gmod for a couple years or so, and while this is an issue I’ve only recently been dealing with, it’s definitely handicapped my experience with the game. I also want to state that I wouldn’t be posting this if I hadn’t spent hours looking for alternate solutions online beforehand; most of what I’ve found online has not worked, so this is my “last resort” until I just quit the game for good.

My main issue comes from the final point in joining a game, where I’ve downloaded all the necessary add-ons for the game, and I’m about to start playing. Right when the game is about to let me in, the screen freezes, and (this being the odd thing about the problem) the game spawns me in. I can hear the game, move around, press on in-game menus, and even interact with other players with my mic… I just can’t see. I’ve even memorized the exit screen just to see if I can get back to the main menu, but even then, I still see the “Sending Client Info…” with the backdrop of the game.

To list some of the ways I’ve tried to solve this issue:

  1. I control-alt-deleted my way out to try to re-open the browser, but then I get a black screen instead of the frozen backdrop (now literally blind)
  2. I deleted the cfg folder, which was recreated upon opening the app
  3. I have disabled (then deleted) all my add-ons, from the main menu to inside the garrysmod folder itself
  4. I have switched around numerously with “dx levels”, mine currently between 81 and 90
  5. I have changed the resolution multiple times
  6. I have validated Garry’s Mod probably over 25 times, as well as verified the games Garry’s Mod uses (CS:GO, TF2, etc.)
  7. I have prioritized both Gmod and Awesomium to “high”
  8. I have cleared away everything, and have reinstalled the game numerous times

If there is anyone out there with a sure-fire solution to this issue, I would be beyond thankful. Gmod has been my favorite game on Steam for so long, and I don’t want to lose it because of this minor transition in-game.

Probably a dumb question, but have you tried to run FactoryReset-GMod.bat from your GarrysMod directory? It will delete your config file from Steam Cloud (you can also try to do it by yourself, i think)

I have a couple of players trying to join my server who also have this issue. Have you managed to fix it? and does anyone else know a fix?