Friend cannot connect to Listen Server

My friend got Gmod recently. Fantastic, I thought!

So I decided to show him the ropes.
After taking him through getting the addons, we were set.

I created my listen server so we could play together.

Unfortunately, even after opening ports 27015-27020 on my router and allowing them on my firewall on my computer, my friend is still unable to connect.

Each time I start the server up I type the following commands.
sv_lan 0
ip xx.xxx.xx.xx (otherwise it uses my internal ip)
heartbeat

What do I do to get this working?

Router: Belkin F5D8633-4
OS: Windows 7 Home Premium 64 bit
Firewall/Virus Scanner: Norton Internet Security 2010

has he tried using the “connect” command in the console?
connect <ip>

That is the way he has been trying to connect

have you tried typing “net_start” before you start the game?

Insted of useing a listen server use a real SRCDS server. It dosen’t take long to set up, less laggy and it is just better.

Garry’s Mod wiki page:

SRCDS website:

SRCDS how to:
(Windows)http://www.srcds.com/db/engine.php?subaction=showfull&id=1097362093
(Linux)http://www.srcds.com/db/engine.php?subaction=showfull&id=1098643920&archive=

Download SRCDS:

Visual guide:

Some thing on this guid has changed. Only the link in wich you download SRCDS.

I hoped this helped. Tell me if you need any more infomation.

This wont be an option, running it on my computer results in me not being able to join it, and there isn’t another computer I’m allowed to tinker with.

No I haven’t I’ll try that

EDIT:
OK, put net_start in before starting the game, started it and the put
sv_lan 0
ip xx.xxx.xx.xx
heartbeat

as I usually do. Dont know wheter it will work yet. Is there anyone that wants to see if they can connect if I PM my IP to them?

Then there is a problem because you should be able to join it! I can join on my server.

Last thing I heard that you can’t join your own dedicated server if its running on the computer you want to play on without some console commands - what they are I dont know

Make sure in your router settings that port 27015 and 27016 are both open and forwarded.

Edit: Ignore me, I missed the port bit.

Never had this problem. My desktop hosted a dedi, could connect fine. Windows XP
Did same on my laptop. Worked. Windows 7.

I’m updating the dedi files now too give it another try.

EDIT: The listen server didnt work again. Just resorted to Hamachi. That worked

Hamachi can be very buggy and crash in many many cases. I would use a dedicated server if I where you. Don’t know where you got that shit about not joining your own server.