full bright problem

i have this weird fullbright problem with my map, I have a feeling that it has to do with compiling heres the log

** Executing…
** Command: “c:\program files\steam\steamapps\darkshifter98\sourcesdk\bin\orangebox\bin\vbsp.exe”
** Parameters: -game “c:\program files\steam\steamapps\darkshifter98\half-life 2\hl2” “H:\Mike\Maps\gm_anightinthecity.vmf”

Valve Software - vbsp.exe (Jun 8 2010)
2 threads
materialPath: c:\program files\steam\steamapps\darkshifter98\half-life 2\hl2\materials
Loading H:\Mike\Maps\gm_anightinthecity.vmf
ConVarRef mat_reduceparticles doesn’t point to an existing ConVar
Could not locate ‘GameData’ key in c:\program files\steam\steamapps\darkshifter98\half-life 2\hl2\gameinfo.txt
fixing up env_cubemap materials on brush sides…
ProcessBlock_Thread: 0…1…2…3…4…5…6…7…8…9…10 (1)
ProcessBlock_Thread: 0…1…2…3…4…5…6…7…8…9…10 (1)
Processing areas…Wrote H:\Mike\Maps\gm_anightinthecity.lin
Areaportal leak ! File: H:\Mike\Maps\gm_anightinthecity.lin
Brush 13976: areaportal brush doesn’t touch two areas
done (0)
Building Faces…done (1)
Chop Details…done (0)
Find Visible Detail Sides…done (0)
Merging details…done (0)
FixTjuncs…
PruneNodes…
WriteBSP…
done (0)
writing H:\Mike\Maps\gm_anightinthecity.prt…Building visibility clusters…
done (1)
Creating default LDR cubemaps for env_cubemap using skybox materials:
skybox/sky_borealis01*.vmt
! Run buildcubemaps in the engine to get the correct cube maps.
Creating default HDR cubemaps for env_cubemap using skybox materials:
skybox/sky_borealis01*.vmt
! Run buildcubemaps in the engine to get the correct cube maps.
Finding displacement neighbors…
Finding lightmap sample positions…
Displacement Alpha : 0…1…2…3…4…5…6…7…8…9…10
Building Physics collision data…
done (2) (277138 bytes)
Placing detail props : 0…1…2…3…4…5…6…7…8…9…10
Water found with no water_lod_control entity, creating a default one.
Compacting texture/material tables…
Reduced 1027 texinfos to 783
Reduced 37 texdatas to 33 (913 bytes to 729)
Writing H:\Mike\Maps\gm_anightinthecity.bsp
7 seconds elapsed

** Executing…
** Command: “c:\program files\steam\steamapps\darkshifter98\sourcesdk\bin\orangebox\bin\vvis.exe”
** Parameters: -game “c:\program files\steam\steamapps\darkshifter98\half-life 2\hl2” -fast “H:\Mike\Maps\gm_anightinthecity”

Valve Software - vvis.exe (Jun 8 2010)
fastvis = true
2 threads
reading h:\mike\maps\gm_anightinthecity.bsp
reading h:\mike\maps\gm_anightinthecity.prt
3855 portalclusters
11732 numportals
BasePortalVis: 0…1…2…3…4…5…6…7…8…9…10 (25)
Optimized: 424801 visible clusters (0.00%)
Total clusters visible: 11792128
Average clusters visible: 3058
Building PAS…
Average clusters audible: 3854
visdatasize:3632327 compressed from 3762480
writing h:\mike\maps\gm_anightinthecity.bsp
32 seconds elapsed

** Executing…
** Command: “c:\program files\steam\steamapps\darkshifter98\sourcesdk\bin\orangebox\bin\vrad.exe”
** Parameters: -game “c:\program files\steam\steamapps\darkshifter98\half-life 2\hl2” “H:\Mike\Maps\gm_anightinthecity”

Valve Software - vrad.exe SSE (Jun 8 2010)

  Valve Radiosity Simulator     

2 threads
[Reading texlights from ‘lights.rad’]
[45 texlights parsed from ‘lights.rad’]

Loading h:\mike\maps\gm_anightinthecity.bsp
Setting up ray-trace acceleration structure… Done (0.72 seconds)
17897 faces
31880473 square feet [4590788096.00 square inches]
0 Displacements
0 Square Feet [0.00 Square Inches]
17897 patches before subdivision
651991 patches after subdivision
90 direct lights
BuildFacelights: 0…1…2…3…4…5…6…7…8…9…10 (222)
BuildVisLeafs: 0…1…2…3…4…5…6…
** Executing…
** Command: Copy File
** Parameters: “H:\Mike\Maps\gm_anightinthecity.bsp” “C:\Program Files\Steam\steamapps\darkshifter98\half-life 2\hl2\maps\gm_anightinthecity.bsp”

If you can figure out whats wrong that would be great. BTW i do have a light env.


Valve Radiosity Simulator 
2 threads
[Reading texlights from 'lights.rad']
[45 texlights parsed from 'lights.rad']

Loading h:\mike\maps\gm_anightinthecity.bsp
Setting up ray-trace acceleration structure... Done (0.72 seconds)
17897 faces
31880473 square feet [4590788096.00 square inches]
0 Displacements
0 Square Feet [0.00 Square Inches]
17897 patches before subdivision
651991 patches after subdivision
90 direct lights
BuildFacelights: 0...1...2...3...4...5...6...7...8...9...10 (222)
BuildVisLeafs: 0...1...2...3...4...5...6...

** Executing...
** Command: Copy File
** Parameters: "H:\Mike\Maps\gm_anightinthecity.bsp" "C:\Program Files\Steam\steamapps\darkshifter98\half-life 2\hl2\maps\gm_anightinthecity.bsp"

Vrad is crashing, meaning the lighting data isn’t being written into the bsp.

how do i get it to not crash?

Areaportal leak ! File: H:\Mike\Maps\gm_anightinthecity.lin
Brush 13976: areaportal brush doesn’t touch two areas

That’s not good.

And because the VRAD step that’s breaking is called buildvisleaves, fixing that might be the path to fixing the VRAD crash.

hmm, I’ll see what i can find

[editline]11:48AM[/editline]

Is there a way to fix build vis leaves?

Fix the leak.

Area portals aren’t allowed to see eachother. They have to be touching at least two world brush faces to not leak.

k im sorry for being a newb but what is a area portal and a world brush face.

Im sorry im new at source

I world brush face is a brush that is not an entity of any kind. And areaportal is something that you have used to optimise the map.

ok im just dumbing it down brush face is like blocks (the stuff you use to make your maps) pretty much like the structure of the map? not the stuff that makes the map works (fans, lights, flying crap ect) and area portal is for stuff like optimizing right? ok again IM A NOOB! :frowning:

Its right.

World brushes are just when you place a brush down and only resize, or don’t do anything to it.

ok i THINK i found the leak. so i loaded the point file and a button (func_button) had a red line point toward the wall, i folowed the line and the line went into the sidewalk and ended somewhere IN the sidewalk.
so now all i need to do is fix the leak.
how do i fix it?

Is the sidewalk tied to a func_areaportal or something?

Is the sidewalk any type of entity? Even a func_detail?

the sidewalk doesnt have any entitys on it not even an areaportal

any solutions?

Perhaps you should look at this;
http://rvanhoorn.ruhosting.nl/optimization.php?chapter=areaportals

thx firegod i’ll look into it