Fullbright map.

Once again, my map has gone fullbright and I have no idea why.

Compile log:



** Executing...
** Command: "e:\program files (x86)\steam\steamapps\common\Source SDK Base 2013 Multiplayer\bin\vbsp.exe"
** Parameters: -game "e:\program files (x86)\steam\steamapps\common\Source SDK Base 2013 Multiplayer\customConfig" "e:\downloads\rp_unsc_hilander_e2a"

Valve Software - vbsp.exe (May 14 2014)
4 threads
materialPath: e:\program files (x86)\steam\steamapps\common\Source SDK Base 2013 Multiplayer\customConfig\materials
Loading e:\downloads\rp_unsc_hilander_e2a.vmf
material "/hilander_floor_01" not found.
Material not found!: /HILANDER_FLOOR_01
ConVarRef mat_reduceparticles doesn't point to an existing ConVar
material "/hilander_wall_01" not found.
Material not found!: /HILANDER_WALL_01
material "/medbay_wall" not found.
Material not found!: /MEDBAY_WALL
material "/hilander_exterior_wall_01" not found.
Material not found!: /HILANDER_EXTERIOR_WALL_01
material "/hologrid" not found.
Material not found!: /HOLOGRID
material "/hilander_cafeteria_wall" not found.
Material not found!: /HILANDER_CAFETERIA_WALL
material "/hilander_door" not found.
Material not found!: /HILANDER_DOOR
Could not locate 'GameData' key in e:\program files (x86)\steam\steamapps\common\source sdk base 2013 multiplayer\customconfig\gameinfo.txt
fixing up env_cubemap materials on brush sides...
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (1)
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
Processing areas...done (0)
Building Faces...done (0)
FixTjuncs...
PruneNodes...
WriteBSP...
done (1)
writing e:\downloads\rp_unsc_hilander_e2a.prt...Building visibility clusters...
done (0)
Creating default LDR cubemaps for env_cubemap using skybox materials:
   skybox/sky_day01_01*.vmt
 ! Run buildcubemaps in the engine to get the correct cube maps.
Creating default HDR cubemaps for env_cubemap using skybox materials:
   skybox/sky_day01_01*.vmt
 ! Run buildcubemaps in the engine to get the correct cube maps.
Finding displacement neighbors...
Finding lightmap sample positions...
Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
material "/ffg_decal" not found.
material "/unsc_logo" not found.
material "/hilander_decal" not found.
material "/unsc_decal" not found.
material "/medical_logo" not found.
Building Physics collision data...
done (0) (231936 bytes)
Placing detail props : 0...1...2...3...4...5...6...7...8...9...10
Compacting texture/material tables...
Reduced 509 texinfos to 373
Reduced 35 texdatas to 30 (878 bytes to 577)
Writing e:\downloads\rp_unsc_hilander_e2a.bsp
3 seconds elapsed

** Executing...
** Command: "e:\program files (x86)\steam\steamapps\common\Source SDK Base 2013 Multiplayer\bin\vvis.exe"
** Parameters: -fast -game "e:\program files (x86)\steam\steamapps\common\Source SDK Base 2013 Multiplayer\customConfig" "e:\downloads\rp_unsc_hilander_e2a"

Valve Software - vvis.exe (May 14 2014)
fastvis = true
4 threads
reading e:\downloads\rp_unsc_hilander_e2a.bsp
reading e:\downloads\rp_unsc_hilander_e2a.prt
4411 portalclusters
10688 numportals
BasePortalVis:       0...1...2...3...4...5...6...7...8...9...10 (4)
Optimized: 336420 visible clusters (3.96%)
Total clusters visible: 8486880
Average clusters visible: 1924
Building PAS...
Average clusters audible: 2711
visdatasize:4607825  compressed from 4869744
writing e:\downloads\rp_unsc_hilander_e2a.bsp
6 seconds elapsed

** Executing...
** Command: "e:\program files (x86)\steam\steamapps\common\Source SDK Base 2013 Multiplayer\bin\vrad.exe"
** Parameters: -bounce 2 -noextra -game "e:\program files (x86)\steam\steamapps\common\Source SDK Base 2013 Multiplayer\customConfig" "e:\downloads\rp_unsc_hilander_e2a"

Valve Software - vrad.exe SSE (May 14 2014)

      Valve Radiosity Simulator     
4 threads
[Reading texlights from 'lights.rad']
[45 texlights parsed from 'lights.rad']

Loading e:\downloads\rp_unsc_hilander_e2a.bsp
Setting up ray-trace acceleration structure... Done (0.37 seconds)
30228 faces
2 degenerate faces
64068628 square feet [9225882624.00 square inches]
0 Displacements
0 Square Feet [0.00 Square Inches]
30226 patches before subdivision

** Executing...
** Command: Copy File
** Parameters: "e:\downloads\rp_unsc_hilander_e2a.bsp" "\rp_unsc_hilander_e2a.bsp"


** Executing...
** Command: " "
** Parameters: -allowdebug -game "e:\program files (x86)\steam\steamapps\common\Source SDK Base 2013 Multiplayer\customConfig" +map "rp_unsc_hilander_e2a"


And no, it isn’t only the missing textures that are fullbrighting, it is all of them.

It’s not doing light calculation. Check your compile settings, ensure VRAD is checked, and try going to Map… Load Pointfile.

If it asks you “Load default Pointfile?” There’s a leak, and you can use the red line it draws to track the leak down. If it open a file browser, there’s no leak at present.

I did try loading the pointfile, however, no pointfile exists for this map for some reason.

Pointfiles aren’t generated unless the map has a leak, which yours doesn’t.

It looks like VRAD is crashing before it starts doing light calculations for whatever reason. It probably has something to do with the missing textures because textures are required for radiosity calculations.

To replace missing textures easily, go to Map… Check for Problems and find the batch of missing textures. Copious use of the replace button on the face edit window follows.

That’s good then, it means you have no leak.

Edit: apparently opening multiple tabs, eating lunch then replying without refreshing first wasn’t a smart choice

I changed all of the custom textures to default ones, but I’m still having the same problem.

Compile log:



** Executing...
** Command: "e:\program files (x86)\steam\steamapps\common\Source SDK Base 2013 Multiplayer\bin\vbsp.exe"
** Parameters: -game "e:\program files (x86)\steam\steamapps\common\Source SDK Base 2013 Multiplayer\customConfig" "e:\downloads\rp_unsc_hilander_e2a"

Valve Software - vbsp.exe (May 14 2014)
4 threads
materialPath: e:\program files (x86)\steam\steamapps\common\Source SDK Base 2013 Multiplayer\customConfig\materials
Loading e:\downloads\rp_unsc_hilander_e2a.vmf
ConVarRef mat_reduceparticles doesn't point to an existing ConVar
Could not locate 'GameData' key in e:\program files (x86)\steam\steamapps\common\source sdk base 2013 multiplayer\customconfig\gameinfo.txt
fixing up env_cubemap materials on brush sides...
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (1)
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (1)
Processing areas...done (0)
Building Faces...done (0)
FixTjuncs...
PruneNodes...
WriteBSP...
done (1)
writing e:\downloads\rp_unsc_hilander_e2a.prt...Building visibility clusters...
done (0)
Creating default LDR cubemaps for env_cubemap using skybox materials:
   skybox/sky_day01_01*.vmt
 ! Run buildcubemaps in the engine to get the correct cube maps.
Creating default HDR cubemaps for env_cubemap using skybox materials:
   skybox/sky_day01_01*.vmt
 ! Run buildcubemaps in the engine to get the correct cube maps.
Finding displacement neighbors...
Finding lightmap sample positions...
Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
Building Physics collision data...
done (1) (231931 bytes)
Placing detail props : 0...1...2...3...4...5...6...7...8...9...10
Compacting texture/material tables...
Reduced 474 texinfos to 340
Reduced 29 texdatas to 22 (780 bytes to 400)
Writing e:\downloads\rp_unsc_hilander_e2a.bsp
5 seconds elapsed

** Executing...
** Command: "e:\program files (x86)\steam\steamapps\common\Source SDK Base 2013 Multiplayer\bin\vvis.exe"
** Parameters: -fast -game "e:\program files (x86)\steam\steamapps\common\Source SDK Base 2013 Multiplayer\customConfig" "e:\downloads\rp_unsc_hilander_e2a"

Valve Software - vvis.exe (May 14 2014)
fastvis = true
4 threads
reading e:\downloads\rp_unsc_hilander_e2a.bsp
reading e:\downloads\rp_unsc_hilander_e2a.prt
4411 portalclusters
10688 numportals
BasePortalVis:       0...1...2...3...4...5...6...7...8...9...10 (9)
Optimized: 336420 visible clusters (3.96%)
Total clusters visible: 8486880
Average clusters visible: 1924
Building PAS...
Average clusters audible: 2711
visdatasize:4607825  compressed from 4869744
writing e:\downloads\rp_unsc_hilander_e2a.bsp
14 seconds elapsed

** Executing...
** Command: "e:\program files (x86)\steam\steamapps\common\Source SDK Base 2013 Multiplayer\bin\vrad.exe"
** Parameters: -bounce 2 -noextra -game "e:\program files (x86)\steam\steamapps\common\Source SDK Base 2013 Multiplayer\customConfig" "e:\downloads\rp_unsc_hilander_e2a"

Valve Software - vrad.exe SSE (May 14 2014)

      Valve Radiosity Simulator     
4 threads
[Reading texlights from 'lights.rad']
[45 texlights parsed from 'lights.rad']

Loading e:\downloads\rp_unsc_hilander_e2a.bsp
Setting up ray-trace acceleration structure... Done (0.97 seconds)
30204 faces
2 degenerate faces
64068628 square feet [9225882624.00 square inches]
0 Displacements
0 Square Feet [0.00 Square Inches]
30202 patches before subdivision

** Executing...
** Command: Copy File
** Parameters: "e:\downloads\rp_unsc_hilander_e2a.bsp" "\rp_unsc_hilander_e2a.bsp"


** Executing...
** Command: " "
** Parameters: -allowdebug -game "e:\program files (x86)\steam\steamapps\common\Source SDK Base 2013 Multiplayer\customConfig" +map "rp_unsc_hilander_e2a"


Try compiling it with normal and not fast.

Last time I did that, it took over 5 hours to compile. I’ll give it a shot overnight.

Woah. That’s not right. Mind uploading the vmf?

Hey, did you have an issue where if you compiled it on normal, lighting would be fucked up and make lots of brushes dark black?

Yeah, that’s exactly what happened last time.

[editline]2nd December 2014[/editline]

Add me on Steam, I’ll send it to you there.

If you figure some solution, PLEASE post it here, since I’m having the exact same thing myself.

If you have a 3D skybox make sure that no huge model or brush is possibly casting a shadow over the entire map like a clouds model or something. Had this issue before. If that doesn’t work or isn’t the case try remaking your light_environment or messing with its settings.

Also I’d go through again and attempt to func_detail as many things as possible as that never hurts and could hopefully cut back on some compile time if it is truly taking that long.

Check alt-p too in case there are any other random errors that could be causing something.

Is there any way I could keep the big brush at the top of the map (the ship) without it fullbrighting?

Try this in Vrad -noskyboxrecurse

My current map has some large brushes in the skybox to simulate planets-- each one is formatted like this:
“UnlitGeneric”
{
“$basetexture” “skybox/bg_basis”
“$translucent” “1”
“$nofog” “1”
}

I think the key thing here is $translucent-- VRAD should ignore brush faces with translucent textures on them, I believe.

If that happens it most likely means you have to many lights on one face. The max number of light styles you can have per face is 4. Keep in mind Source assumes any named light can have an on and an off state and even if two lights in an area turn on and off at the same time if they have different names it still counts as a separate light style.

Now I’m sure you are asking “But it looks fine in fast why not in normal or final?” and the answer is that when you do a fast compile vrad uses some quicker algorithms that are not as accurate. Have you ever played a map and noticed some awful light bleed on brush work? That’s because they shipped with a fast compile.

5 hours is insanely high you really should look into optimizing http://www.optimization.interlopers.net/