Func_occluder isn't occluding properly

I’ve added occluders behind certain areas in my map, such as hedges and walls, but they aren’t working correctly for props near them. It just completely ignores them and keeps rendering them, as if the occluder wasn’t here.
However, when you walk away from them, it magically starts working as it should.

r_visocclusion 1; mat_wireframe 0

https://dl.dropboxusercontent.com/u/33369101/TTT_Robbery/Occluders/ttt_robbery_2_Dev_d480006.jpg[/T]

r_visocclusion 1; mat_wireframe 1 - Notice how the car appeared in here, but wasn’t displayed as a box in the previous screenshot.

[T]https://dl.dropboxusercontent.com/u/33369101/TTT_Robbery/Occluders/ttt_robbery_2_Dev_d480007.jpg[/T]

After walking away a bit, it suddenly occludes.
r_visocclusion 1; mat_wireframe 0

[T]https://dl.dropboxusercontent.com/u/33369101/TTT_Robbery/Occluders/ttt_robbery_2_Dev_d480008.jpg[/T]

r_visocclusion 1; mat_wireframe 1

[T]https://dl.dropboxusercontent.com/u/33369101/TTT_Robbery/Occluders/ttt_robbery_2_Dev_d480009.jpg[/T]

Also, when you get too far away, they dissapear completely.
r_visocclusion 1; mat_wireframe 0

[T]https://dl.dropboxusercontent.com/u/33369101/TTT_Robbery/Occluders/ttt_robbery_2_Dev_d480014.jpg[/T]

r_visocclusion 1; mat_wireframe 0

[T]https://dl.dropboxusercontent.com/u/33369101/TTT_Robbery/Occluders/ttt_robbery_2_Dev_d480015.jpg

Any possible solutions?

Quote from dev wiki -

“Calculations of model visibility ingame is done in real time and is not in the final compile process. Use func_occluders wisely because they do calculations in real time and can cost alot of CPU if there are too many in a map.”

If I were you I wouldn’t bother with them at all, maybe use fading distances etc

I’m aware of the disadvantages of occluders and that they’re computed realtime, but the problem is that they aren’t working at all if you’re near or vice versa.
Also, I’m using fading distances, but in some cases it’s not applicable.

Edit: Fixed by setting “Max ocludee area” in worldspawn to 100. I have no idea why isn’t it set to that value by default. >_<

This must be new, there’s even an sdk map that showcases the occluder with the wireframe on and demonstrably hides models…

[editline].[/editline]

I completely misread, nothing’s out of line here.