G-mod Npcs, Playermodels,Vehicles and models spazzing out

Allright, so I’ve been playing G-mod a while now and this is definitely new. After the most recent update, all of the NPC’s, Playermodels, and basically every model has started to spazz out. I will place a Combine Elite only to watch in horror as his body falls apart and his model is torn to shreds and then he turns invisible. Same thing happens with any other Npc. Now I’m a fan of attaching thirty billion thrusters onto a vehicle and seeing what happens, but when I place a vehicle, half of the model will turn sideways. Its a little hard to place anything on a vehicle when half the model is sideways. I also have been doing my regular building, and my objects will spaz and disappear. Even my guns are broken as sometimes I can’t even see my weapon, or when i shoot a bolt from the cross bow, everything has a meltdown and the bolt turns into the cross bow then to the SMG, then disappears. Also, it seems absolutely 0 of the player models work. Its getting a wee bit annoying. I’m kinda hoping I dont need to buy a ton of other games just so this one works, because thats a waste of my money. Hopefully there’s a fix for this. Thank you. I can load some screen shots if needed.

Disable all workshop addons and remove any legacy addons you might have. Otherwise, reinstall your game.

Alright, so I guess I’ll re-install since I’ve already tried deleting all the addons :stuck_out_tongue: I’ll update you when its done.

Okay so I tried re-installing and the game is still spazzing out. Do I have to have Half-life and CS so I can play this game properly? If so thats…thats really dumb. I’d rather not buy a game that requires me to buy other games.

[editline]21st August 2014[/editline]

Btw, none of those addons are enabled. I also do not feel like looking for and unsubscribing 468 addons.

What video card do you have?

This was easier.

Open “Run” window ( Windows key + R ), type dxdiag and show us the Display tab.

I’m guessing that G-mod now requires a better Vid card? It used to run perfectly so.

I said the Display tab, not the System tab.


-dxlevel 8

?

Sorry about that. I’m extremely tired.

You have 3 year old drivers installed, try updating them.

  1. It’s dxlevel 80.
  2. You should never be using DirectX 8 with GMod.

Well where would I find driver updates? I tried previously and well, they where just a ton of virus’s.

Well, I had a retard moment haha. But I went to Wndows update and updated everything possible and its still glitching out. :confused:

On AMD’s website, where else.

[editline]24th August 2014[/editline]

http://forum.facepunch.com/showthread.php?t=1355397

Thats actually really helpful thank you! :smiley:

Well its still not working and I have found a few new things. SMG casings that fall out of the gun as your shooting, take on the model of the smg itself O_O RPG’s rockets are people with fire coming out of their feet…I dont even know what this nightmare is anymore. I’ve updated everything, I think my next move is to completely delete my G-mod folder and re-download. Pretty sure uninstall didnt delete everything.