G-Sync Not Working

I’ve recently upgraded to a g-sync monitor and rust seems the only game that g-sync doesn’t engage, fps is always below monitor max refresh and monitor just sits at max. Yes the game is running on full screen! :stuck_out_tongue:

Anyone else seeing this?

-snip.

G-sync does not has to be supported by the application. The reason why it’s not working is, that rust does not run in exclusive fullscreen, but in borderless window mode. And as far as I know, this mode isn’t fully supported yet. Hardi, just google for ‘g-sync borderless window’ for more. :slight_smile:

Oh I appreciate that, but my understanding of how G-Sync worked meant that it was separate to the game.

Am I wrong? I guess all I want is someone else to say… yes me too, it doesn’t work! Or no, just tick this box to magically fix everything!

[editline]16th March 2016[/editline]

Oh is that all it is! There’s an option for that in Nivdia

Thanks chap I’ll give that a whirl

Just be aware that if you use G-sync on all windowed applications it can screw with a few of them and sometimes even lock the framerate to 30.
Just a heads up.