Game broken on wine?

As of late i’ve been largely unable to run the game under wine-staging 251 or wine at all, for that matter.
It will attempt to load into the menu and just hang and require force closing, of the dozens of times I’ve tried loading it, it has succeeded maybe once.

I have no addons, have ran the factory reset several times and have tried two accounts.

I think it is due to awesomium_process hanging… but I’m not 100% sure on that, could someone else try to run the game in wine and confirm? Or anyone knows a way of disabling awesomium?

The game runs natively on Ubuntu, you don’t need Wine for it to work.

I am aware, but it’s not available natively on my OS.
Do you know what was changed to cause this…? Every other source game works.

If it was intentional please issue some kind of work around.

Firstly what OS are you trying to run it on?

FreeBSD 11.1.

Have had a long time of flawless operation until some updates ago.

I have some errors here that may be related …

Steam_SetMinidumpSteamID: Caching Steam ID: 75561197999006300 [API loaded no]

and

fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:ntdll:EtwEventRegister ({47a9201e-73b0-42ce-9821-7e134361bc6f}, 0x3f006bd0, 0x3f043cf0, 0x3f043ce8) stub.
fixme:ntdll:EtwEventRegister ({58a9201e-73b0-42ce-9821-7e134361bc70}, 0x3f006bd0, 0x3f043d28, 0x3f043d20) stub.
fixme:ntdll:EtwEventRegister ({3fa9201e-73b0-43fe-9821-7e145359bc6f}, 0x3f006bd0, 0x3f043dd0, 0x3f043dc8) stub.
fixme:ntdll:EtwEventRegister ({1432afee-73b0-42ce-9821-7e134361b433}, 0x3f006bd0, 0x3f043d60, 0x3f043d58) stub.
fixme:ntdll:EtwEventRegister ({4372afee-73b0-42ce-9821-7e134361b519}, 0x3f006bd0, 0x3f043d98, 0x3f043d90) stub.
Steam_SetMinidumpSteamID: Caching Steam ID: 76561197999006300 [API loaded no]
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
^Cfixme:console:CONSOLE_DefaultHandler Terminating process 66 on event 0
fixme:ntdll:EtwEventUnregister (deadbeef) stub.
fixme:ntdll:EtwEventUnregister (deadbeef) stub.

At this point I am not even sure what the issue is anymore.

[editline]17th October 2017[/editline]

I understand that this is not officially supported… but it was working fine before, what kind if ridiculous change was there?

[editline]17th October 2017[/editline]

Also I should say the linux version of this game tends to crash on servers that use more than 2.7gb~ of ram, this is kind of a workaround.

So I just tried this on my other Freebsd 11.1 machine, only this one has intel graphics.
It does work, which leads me to believe this is a new issue with the driver or the patch-nvidia script that come with wine(staging)…

So, sorry for wasting your time and please lock my thead. Thanks