Game Crash from Access Violation

Alright so there’s a gamemode called Ground Control as seen here (gamemode on GitLab) and everytime the round restarts or ends, or more specifically when it tries to read files locally, the game will crash. I’ve seen others that have had this issue before, not on this gamemode but with HL2 and GMod in general with little to no luck on how to fix it.

What I’ve tried:
• Using the GMod factory reset .bat
• Deleting local game cache and reinstalling
• Unsubscribing from all addons
• Mounting only CSS and HL2 (as used by the gamemode)

From Visual Studio:


Dump File:	hl2_161029_crash_2016_11_28T22_46_18C0.mdmp : D:\SteamLibrary\SteamApps\common\GarrysMod\hl2_161029_crash_2016_11_28T22_46_18C0.mdmp
Last Write Time:	11/28/2016 5:46:18 PM
Process Name:	hl2.exe : D:\SteamLibrary\steamapps\common\GarrysMod\hl2.exe
Process Architecture:	x86
Exception Code:	0xC0000005
Exception Information:	The thread tried to read from or write to a virtual address for which it does not have the appropriate access.
Heap Information:	Not Present

From Event Viewer:


Faulting application name: hl2.exe, version: 0.0.0.0, time stamp: 0x5771752c
Faulting module name: ntdll.dll, version: 6.3.9600.18146, time stamp: 0x5650afd4
Exception code: 0xc0000374
Fault offset: 0x000e5914
Faulting process id: 0x20
Faulting application start time: 0x01d249c808da2b88
Faulting application path: D:\SteamLibrary\steamapps\common\GarrysMod\hl2.exe
Faulting module path: C:\Windows\SYSTEM32
tdll.dll
Report Id: 5fb1c396-b5bb-11e6-82de-fcaa142125b0

From Dumper: http://dumps.metastruct.uk.to/dumper.py?dump=hl2_161029_crash_2016_11_28T19_37_1C0.mdmp

Any information to alleviate the issue is appreciated, thanks.

Should be fixed in the next update. Verify by testing it in the Dev branch.

Ah very good, it works, thanks a lot.

Edit: Any particular reason why it seemed to only crash for me?