Game failing to update after today

So after today’s update, me and several others are unable to play rust, it says its updating, when it finally reaches 100%, it resets back to 0%, starting the process over again, it’s done this about 15 times now, very annoying, please find a quick fix thanks.

I just closed steam and tried again. It worked.

Restarting steam fixed it for me. However, still can’t see official servers. Can anybody else?
Thanks :slight_smile:

I did this, closed all steam applications and the exe steam that runs afterwards VIA task manager, alas it did not work. Instead now it freeze’s at 100% and say’s 0 seconds remaining, its been this way for about 5 minutes now… :confused:

EDIT: appears to be launchable now, thanks.

it works for me but everything was reset and refreshed. sadly the games frame rate as dropped below 30 though… wtf?

Also animals seem to all be stuck in place and it appears the whole map is forest now with no stone/metal/sulfr. Animals are also disappearing after dying.

I put everything to MAX settings to test FPS, still ran as normal.

Unable to connect to offical server’s though, it stops on “creating terrian math”. Also the owner of a very high respected community server called Rustafied is unable to get his server going, and seeing as there is only 4 pages of servers, I’m assuming a lot of other server owner’s are also unable to launch there servers…

have you been in a server that has been updated along with rust? otherwise, ofcourse you wouldn’t notice anything different.

Yup, game run’s great still. This low FPS has to be client side as me and my friends run the game perfectly still. Not a single drop in FPS.

I play with motionblur turned off, if that make’s any difference.