"Game is currently unavailable"

Ok so I’ve searched on google and on FP, and nothing has prevailed.
I was enjoying my Garry’s Mod, coding some Lua and testing a few things.
When BAM!
Garry’s Mod mysteriously shuts down!
So as a first resort I was like “zomfg what the fuck lol” and restarted steam and tried.
CAME UP WITH THE SAME FUCKING ERROR!
At this stage I was like “ZOMFG FUCK FUCK FUCK”
So I googled it, and tried restarting computer, verifying cache, defragging, and running a source game beforehand.
NOTHING WORKED
HELP MEEEEEEEEEEEEEEEEEEEEE
Yours sincerely, Volcomchamp

Calm down and stop using caps.
this happends to steam games sometimes, it usally gets to work again. By the way try to read what it says: Game is CURRENTLY unavailable"
that means only for a while…

What is the error?

Well considering it’s been doing this for like, 5 or 6 hours,
I think the key word “CURRENTLY” is a load of Bullshit.

EDIT:
When I run GMod it says “Game is currently unavailable. Please try again later”

Delete clientside.blob and steam.dll in your steam directory.

It will start working again.

Then it comes up with “Unable to load library steam.dll”
:\

Renaming them is safer.
Edit:Too late.
Reinstall Steam.

I didn’t empty my bin, and put them back in.
What can I do?

Have you tried restarting steam? I sometimes get that message and it fixes when i restart my computer/steam.

Edit: Never mind I didn’t see where you said you had already tried that. Sorry :frowning:

Tried it, reinstalling steam and seeing what happens :
Nope didn’t work.
I’m in a pickle right now.

I was thinking for a second that you were using a sort of steam hack. But when i read more i found out you didn’t

I’m not.
Also, that gave me absolutely no help.
I NEED HELP.

Edit:

Ok fixed,
I just redownloaded garrysmod :
Starting from scratch on my mod… sigh

lolololololololololoolooloooooolooloololol

arshwipe BE HELPFUL! I always get that for like 5 mins.

Late poster is late, but for everyone else who has this problem and finds this thread, this problem tends to be due to h2.exe running in the background even though the game isn’t up.

Go into task manager and shut off the process hl2.exe, game should start working again.

There you go champs.

Im having the exact same problem. iv tryed to open i a mounth now and the error STILL apears… damn i hate steam sometimes.

[editline]02:51PM[/editline]

what should i do?

And indeed this man speaks the truth. This may be a old topic, but it still happens.

Also, its the first page in google, so a confirmation would help people fix the problem easier.

Just launch Gmod through the game window in steam, not a shortcut.
Worked for me

Make sure nothing is using any of GMod’s DLLs (easily checked by deleting the folder and see if Windows bitches that a DLL is in use).

If something is, download Unlocker (google it) and use that on the file.

I love you, sure enough i had a hl2.exe running in the background.

steam is a great idea but its not infallible.

one pissed gmod user XD, oh by the way i loved your “your is in reference to the guy who started the thread” i loved your opening lines, ZOMFG FUCK FUCK. haha