Game is dark...

im not sure what i did . but the game is ALLOT darker … i dont know why . i havent changed any settings . after the update . anyone now how to fix it … ?

every other game works fine . with no changes . just rust … not sure what i did

Edit

The solution is to run this -force-d3d9

+1

Did you alt+tab at all? There’s a glitch that will darken your display when it minimizes.

i could have . not to sure . how do i fix it ?

I noticed this the other day on the Dev branch. It’s permanently dark.

your joking with me right ? :open_mouth:

Hey,

got the same problem here. Downloaded Patch und it’s so f****** dark. In the menu I can’t read “Rust” on the background.

When I’m in game it’s nearly black.

No, I didn’t press Alt + Tab and I think Fishy, Flushy oder Flashy (the guy who noticed it first) didn’t press Alt + Tab, too.

[editline]21st May 2015[/editline]

http://forum.facepunch.com/showthread.php?t=1466750&p=47774972#post47774972

Before update i get darker Rust after Alt+Tab. But now, after patch game just starts like this, even menu is extremly dark. Its something with monitor display, cause there is also problem with fullscreen resolution (part of the screen is cut, and menu buttons respond while my curosor is 5 inches off target).

Good update Garry! :smiley:

The game is darker
Colours are wierd in game
and much more. Game is absolute not playable. I hope they get a fix or
get back to the old update soon. I hope we dont need wait after the weekend because
this is realy bad this time.

Can you right click on Rust in your Steam Library and select properties and then select Set Launch Options… and add -force-d3d9 and launch Rust again.

Also i had a friend who disabled “colour grading” to fix the added dark after alt-tabbing.

in my opinion, nights could (and should) be even more dark. This is not Disneyland, you should need a light source to get things done at night.

my system is using dx11 and im not expecting any troubles with the colors

Same problem here

Some useful info:

  1. Are you running in DirectX 11 (is your computer dx11 capable)
  2. Does it happen in fullscreen mode
  3. Does it happen in windowed mode
  4. Does it happen when running-force-d3d9 on the launch options

Thanks for the tip Holmzy, this has resolved this particular issue for me at least!

I have a DX11 capable card,
problem did not happen windowed,
does happen in fullscreen (max res I can play at is 2560x1440, if i try any higher it CTD when loading the world)
No darkness when forcing D3D9

i tried it on max res and it fixed the dark screen but i dont know for FPS

So what is the solution of all this?

Will it be some patch/fix for it or?

When i forced the -force-d3d9 in options it fixed my issue from dark in game this happend on the last patch may i add and i used to get black textures when tabbing out before i have Phenom ii x4 @ 3.6 ghz and 7870 myst with 6 Gb ram so maybe an AMD card issue i could be wrong maybe its only potatoe machines like mine :stuck_out_tongue:

i went in to properties but i could not find -d3d9 … anyone mined explain to me where to find it exactly?

thanks in advance

When in properties click on set launch properties then paste this command in there then launch rust