Game is unavailable

I’ve recently been getting “This Game is Currently Unavailable” errors from Steam. The only way I’ve been able to start Garry’s Mod is through a batch file in the main garrysmod folder. (NOT torrented).

Things I have done:

  • Verified
  • Deleted ClientRegistry.blob
  • Deleted everything except Steam.dll, steamapps, and Steam.exe from the Steam folder

Deathmatch Classic worked fine, so it’s an issue between Garry’s Mod and Steam.

And now for the “Answer the questions I know you want to ask!” bit:

You need to do <thing I’ve already tried here>, fuckwit.
You need to learn to read, fuckwit.

Clean your addons.
Not even the shittiest addon can fuck this up, try again.

lolwarez
lolno.

I have this problem too.
Not helpful.

Go to hell
I’m already there, even without this GMod vs Steam bullshit.

What’s in the batch file?

The batch file itself simply contains the same thing Steam executes to get Garry’s Mod working (not saying what due to it helps pirates, y’arr)

Try rebooting, and just wait a while, it can just happen sometimes inexplicably.

I’ve had this error too sometimes. I use the task manager’s Processes tab to close “hl2.exe” to fix it. :slight_smile:
(Edit: You need to learn to close hl2.exe, fuckwit ;P)

It’s not running when this happens, but nice use of fuckwit.

Besides, if hl2.exe is running when I try to start a game, Steam tends to freeze and need killing through Task Manager