Game never launches.

Everytime i try to launch the new rust from steam it will never launch.I’ve tried launching legacy and it works,I’ve launched the RUST exe file by itself and it worked but i kept getting kicked of because of no VAC.There are no crash logs in my folder either.

I run a x64bit Windows 7 i5 4GB

I’m currently installing .net framework 4.5.2 and seeing if that fixes the problem,I’ll post back if it works or not.

[editline]9th November 2014[/editline]

It works, YESSSSSSSSSSS!

[editline]9th November 2014[/editline]

If rust doesn’t launch for you,Download .net framework 4.5.2
and/or opt into dev mode via rust properties.

Both suggestions didn’t work for me.

solved my problem by complete uninstallation of comodo firewall.

any1 got news to this?
anyone working on it?
or did i really threw 20€ out my window?

support wrote me to re-install the game after 4 days… did that thousand times, still not working. no i dont use bullguard or comodo firewall and i added rust as exeption, uninstalled anti-virus (avira) and did many other things (delete registrys…"). hope you find a solution soon…

(hope someone’s working on that…)

Still not working for me either… tried everything I could think of, and stuff suggested by facepunch support and others. Everything short of reinstalling Windows, which I’m not going to do just for 1 game…