Game Servers Missing/Can not connect via IP

Just yesterday I tried to connect to a Gmod server I frequently play that is in my Favorites and It said connection failed after 6 retries. I tried to connect via console and got the same error. Now most the game servers aren’t even showing up. The server is online (confirmed with multiple players and the owner). Everyone said it could be my firewall so I turned it off. I tried reinstalling Gmod and Steam. I have rebooted my router and modem. Changed my IP address and DNS. I am at a loss, Can’t seem to figure out why they are appearing as offline and not responding when they are online. (The issue is with every computer I own as well) Any ideas?

Sounds like a firewall on your router or something is blocking all connections. Any other games preventing you from playing online?>

Yeah if it’s with every computer you own it really sounds like router or firewall setting. Try plugging your computer directly into your modem rather than through the router. If that works, reset the router imo, and re-add any port forward triggering you have set. :smiley:

Try disabling your firewall. See if you’re able to connect.

Windows 8 firewall

  1. Open the Control Panel
  2. Click on Windows Firewall.
  3. If the Windows Firewall is enabled, the Windows Firewall state will be On. To turn it off, in the left navigation pane, click on Turn Windows Firewall on or off.
  4. In the Customize Settings window, select Turn off Windows Firewall and click OK.

Vista and Windows 7 firewall

  1. Click Start and in the Search for Programs and Files text box, type firewall and press Enter.
  2. In the search results, click Windows Firewall.
  3. If the Windows Firewall is enabled, the Windows Firewall state will be on. If it is on, click Change settings or Turn Windows Firewall on or off in the left column.
  4. In the Firewall Settings window, select Off and click OK.

Windows XP firewall

  1. Open the Control Panel
  2. Open Network Connections.
  3. Within the Network Connections window, right-click the Local Area Connection and select Properties.
  4. Within the Local Area Connection Properties window, click the Advanced tab.
  5. Finally, uncheck the Protect my computer and network by limiting or preventing access to this computer from the Internet option.