Game startup failed. Error Code: 22

I’m just reporting a workaround to an EAC bug.
I could not play Rust since August 2015 to now, due to a weird bug that the Rust launcher fails to load with EAC enabled (and gives no crash report)

I had an EAC error “Rust Launcher Error: LauncherFailure - Game startup failed. Error Code: 22” when I try to launch Rust through Steam.
I’ve tried reinstalling Rust,
reinstalling Steam,
reinstalling EAC,
disabling anti-virus software,
switching off audio devices,
launching Rust as admin,
using -force-d3d11 in launch parameters,
and changing/removing registry values of EAC.
Nothing above works.

But I reinstalled Rust in another Steam library, it gets to work.
I don’t know exactly why it works now but I think “symbolic link of directory” is the key.
My actual “Program Files” directory lies on D drive(HDD) and I have a symbolic link of the program files directory on C drive(SSD).
I moved the steam library from D drive to another HDD (that is M drive now) so that Rust can startup with EAC.

I hope this info helps to some people struggling with EAC problems.

Thanks for providing this info!

I’m not sure what could be the root cause to this behavior, but e.g. if an anti-virus would’ve put the Rust files into quarantine, then changing the path would explain it. Other than that currently not sure what’s going on, but good to know this for future reference.