Game stuck when getting "sending client info"

some servers i try to join i get all the workshop stuff and then i get to “sending client info…”
then my game just freeze and stuck and i have to close it down via Task manager.
i have tried to uninstall my workshop addons etc… and still cant get in the servers.
its happening only to me . my Friends can get in . i cant get in.

please i need some help thanks.

Hey mate,
How long do you usually wait before closing it using the Task manager? it’s common for the game to be stuck for a minute or two before you fully load in when on “Sending client info…”.

about 15 to 30 min
it should not be this long

Alright buddy, I’d like you to try and run the game in Windowed from now on and download the content pack before joining the server if possible, then let me know if it works. If it doesn’t try to uninstall Garry’s Mod, unsubscribe from all addons and reinstall Garry’s Mod again.
Let it load up to 10 minutes next time you load in Sending Client info, if it still doesn’t work, please reply here. :slight_smile:

well i did what you told me and still the same no change.

Did you unsubscribe from all the addons and then reinstalled Garry’s Mod?
What are your computer specs?

yes i unsub everything then reinstall gmod
ram : 16gb
cpu: i5-4460
GPU: GeForce GTX 1050 Ti

[editline]14th October 2017[/editline]

Solved: needed to completly delete the garrysmod folder the install everyhing fresh