Game will not run on dedicated Nvidia Graphics Card

Hey Guys,
I have a MSI GT60 with a GTX970M which should be able to run the game smoothly. However, the game always runs on the integrated graphics card, even if I change the settings in the nvidia manager to dedicated. I have done some searching around and know that this problem has been happening for a while and to a lot of people. Is there a fix? Do devs give a f*ck about this problem and the laptop users? Thanks!

Are you using the “run with graphic processor” option that is in the nvidia control panel ?

Yeah, chose dedicated over integrated(default global setting).

[editline]10th October 2015[/editline]

credits to Bushelito for the solution. Have fun guys!

After countless searching and jumping between topics, I think I found out the solution.

At first, I tried going through nVidia control panel and tried changing there, but it kept resetting.
Turns out that nVidia didn’t had enough permissions to change anything.

So I did this:
Went to C:\Program Files\ and found the folder “nvidia corporation”.
Then Right clicked -> Properties and then found the permissions.
Then I gave “Full Control” option for all profiles.

After that, changing worked in nVidia control panel (change in the global settings, so that “Preffered graphics card” would be the dedicated graphics card) and Rust actually used the right graphics card.