Game wont launch at all

I have not been able to launch the game from Steam for a very long time now and searching on the web yielded no solutions. When i start the game, my friend list status goes green as if i am in the game, however in about 2 seconds it goes blue again as if it crashed. However i do not get any error messages at all.

My specs: Processor:AMD Phenom II X4 965 BE 3.4GHz
Memory:A-DATA 4GB DDR3 1333MHz
Videocard:ATI HD 5870 Windows 7

I use Comodo firewall and Avast antivirus.

I tried launching the game with avast disabled and Comodo in “gaming mode”, however that didnt work either. I also verified the game cache and still it didnt work.

Legacy works for me, but not the new version.

Are any folders containing crash logs generated in the Rust folder?

While you’re there, run RustClient.exe manually. This will cause you to get kicked from servers if it actually works, but we want to see if it can load the main menu.

There is not crash logs in the Rust folder. I tried running Rustclient.exe manually, however it did the same thing when i tried to launch it through steam. There might be one clue to why its happening. Whenever i log onto my computer, there is an error about .net framework 4.0.30319. I tried installing .net framework 4.0 however it says that i already have the same version installed. Looking at control panel and under installed applications i unistalled 2 programs that were called .net framework and tried installing .net framework 4.0, however that didn’t work because i apparently still have some version installed before.

I’m not sure if it’s the same, but for me when I launch the game I get the grey screens saying ‘BOOTSTRAPPING’, ‘LOADING MENU’ etc, and as soon as I get to ‘LOADING MENU BACKGROUND’, my mouse cursor appears and about 2-3 seconds later I’m back at my desktop. Steps taken:

  • Uninstall using Steam and reinstall
  • Change settings pre-launch (the simple/good dropdown next to resolution)
  • Uninstall using Steam, deleting the entire Rust folder and reinstall
  • Switched branches multiple times
  • Verify intergrity of game files

At one point I did come across an error related to CoherentUI in one of the textfiles in the Rust folder, but I’m not sure if this is the issue and how to solve it.

output_log.txt: https://pastebin.com/iSN6dbz8

I have the exact same problem. I already posted about this a while ago now. Worryingly I also run avast and comodo firewall (yeah already tried a bunch of things if you read my post)
Anyway I’ve submitted a formal ticket on facepunch studios and one of their people asked me to send output_log.txt (in clientdata folder within rust) to them. I’ve done that a few days ago but haven’t heard back from them. I’d advise you to do the same.

Edit: Just browsed thru some forum posts, seems like alot of people having this problem. PLEASE SEND FORMAL TICKETS TO FACEPUNCH STUDIOS. I think its the only we can resolve this problem faster
I’ve already made a reported bug thing here: http://support.facepunchstudios.com/feedback/view/1811-rust-will-not-launch-closes-by-itself
feel free to upvote that or comment
but i think everyone should send in tickets if you have the problem.

Submitted a ticket as suggested by FirstAlpha. Also pasted a link to the error I was talking about in my previous post.

Install .NET Framework 4.5.2.

Hi iScripters thanks for doing that I think the more information the devs have the faster we can get our problem fixed

I had another reply today by facepunch studios - they received my output log file;
but they’re also asking we send them the file error.log from the same folder (rustclient_data)
I’ve searched thru all the subdirectories in rust and I can’t find it the log file
If you happen to have that error.log file, could you send it to them if you have it? Hopefully one of them has replied to you now
I’ve told them that nothing got generated on my end but that other people (count 5 i think on this forum) have the same problem :frowning:

Thank you. I installed .NET framework 4.5.2 and restarted my PC. Then i launched Rust and everything works now. I suggest people who have the similar problem try this solution.

Didn’t work for me :frowning:

cant install that framework version, even tried an framework fix tool, didnt work too :((

submit a formal ticket to facepunch studios, attach your output logs…

output logs from console?

/edit, sry found what you was talking about.
Ive sent them the file, i let you know if they could help me.

//edit
Please do the following:

Right-click Rust in your steam library and select Delete Local Content
Go into your Steam/SteamApps/common/ and delete the rust folder
Exit Steam and launch again as administrator
Re-install Rust


that’s what they wrote me after sending a ticket,
well i’ve re-installed the game for a million times…
but maybe not exactly like he told me to do it.
I’ll find it out, maybe it works… i let you know if i have any news

/ edit: just like expected, didnt work.
maybe i should wait for the rust team to fix it… if not i guess that were 20$ for the trash ^^

keep sending them tickets they cant ignore us its not fair we paid money they should fix

solved my problem by complete uninstall of comodo firewall.

i dont have any firewalls like comodo and bitdefender… :frowning:

Note: I’m having the same issue on Ubuntu 14.10, running the Mesa 10.3 Radeon driver. My screen goes black, not blue.



marcus@Marcus-Desktop:/SteamLibrary/SteamApps/common/Rust$ ./rust
Set current directory to /SteamLibrary/SteamApps/common/Rust
Found path: /SteamLibrary/SteamApps/common/Rust/rust
Mono path[0] = '/SteamLibrary/SteamApps/common/Rust/rust_Data/Managed'
Mono path[1] = '/SteamLibrary/SteamApps/common/Rust/rust_Data/Mono'
Mono config path = '/SteamLibrary/SteamApps/common/Rust/rust_Data/Mono/etc'
displaymanager : xrandr version warning. 1.4
client has 6 screens
displaymanager screen (0)(DVI-1): 1920 x 1080
displaymanager screen (1)(DVI-0): 1440 x 900
Using libudev for joystick management


Importing game controller configs
marcus@Marcus-Desktop:/SteamLibrary/SteamApps/common/Rust$