[GAMEBREAKING] Alt Tabbing Causing MASSIVE errors with rust.

Right now, Alt tabbing in rust is generally game breaking, this only occurs when you are in full screen.

Some gamebreaking effects alt tabbing has had on rust for me:

  • A permanent persisting torch effect that illuminated my base with no one around holding a torch (Replicated by a torch burning out while you are alt tabbed)
  • (Absolutely gamebreaking) Doors appearing open when they are actually closed, you can shoot and do whatever through the doors however you can not walk through them (Replicated by starting with a open door, alt tabbing, and having a friend close it)
  • Airplane noise lasting until you alt tab back in
  • Other various noises persisting till tabbing back in
  • Grass render is delayed when tabbing back in
  • Chat backup

http://img839.imageshack.us/img839/5482/7vys.png

This is my console when I alt tab, notice how it is spammed:

http://img838.imageshack.us/img838/3246/onk8.png

I hope that bringing this issue to light can help the dev’s get it resolved.

Rust has been doing this since the standalone version hit Steam. Alt-tabbing switches the graphics mode (as usually happens when alt-tabbing in and out of full-screen games), but Rust doesn’t quite handle it properly yet.

The workaround is to run in windowed mode or don’t alt-tab.

Don’t listen to this guy. He’s a troll.

You’re using a Nvidia graphic’s card which will automatically lose sync of any application that isn’t being displayed. Enable the always-in-sync option and bam, you’ve fixed the problem and also caused your GPU too stress about all the hidden applications as-well.

I hadn’t heard that the trick is to enable vsync. I have an AMD card.

No need to be rude, assface.

where do you read vsync?

Set it in your Nvidia control panel. You can either set a profile for Rust, or just change the graphics settings to turn vsync on permanently.

Note that vsync will cap your frame rate to 60fps (or the refresh rate of your display), and if it is unable to achieve a constant 60fps it will drop down to 30.

i know that :slight_smile:

but where in this thread do you read vsync helps to get rid of these issues?
all it does is limit your fps to match the hz of your display (short description). it does NOT affect the rendering at all.

what soto is talking about is a kind of override which lets your gpu render EVERY image, whether its on screen or not (so simultaneously to rust its rendering your desktop etc.), all the time. so your graphics card doesnt even realize you alt-tabbed.
the problems are for real, but dis-/enabling vsync wont fix them.

using windowed mode does for now, but without a borderless-option its a nuisance we have to deal with.

Cheers :slight_smile:

Oh, always-in-sync. Dur. Like I said, I don’t have an Nvidia card. The last Nvidia card I had was a 9600 GT. :v:

At any rate, like I said, I didn’t know that there was a specific workaround other than “don’t alt-tab” out there. This is still not a new issue with Rust and not unexpected for an alpha anyway.